Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 x64, kernel 3.2.0-24-generic with an NVidia GTX460 and an Achieva Shimian QH270-Lite 2560 x 1440 monitor connected by a dual-link DVI cable.

I've installed the nvidia-current 313-09 drivers from xorg-edgers (and tried the 310-19 from NVidia). Neither of these drivers read the EDID information from my monitor (/var/log/Xorg.0.log) and default to lower resolutions which my monitor will not display, resulting in a black screen. Full story here

If I replace the high-res monitor with a lower resolution 1600 x 900 monitor it works fine.

How can I force my video card to the resolution I need? Btw the xorg.conf configuration file is deprecated.

share|improve this question
add comment

1 Answer

I finally found a solution - an Edid for my Shimian QH270-Lite here thanks to someone who had the same problem with another Korean 2560x1440 monitor, the Yamakasi Catleap.

I installed the new Edid following instructions posted at ubuntuforums.org, thread 1857772 - sorry I can't post more than two links:

Create an NVidia xconf file with the new edid:

$ sudo nvidia-xconfig --custom-edid=/etc/X11/Shimian_edid.bin

Check your Xorg log for Display Device Name - probably DFP-0, or DFP-1:

cat /var/log/Xorg.0.log | grep connected

which should bring up something like:

(--) NVIDIA(0): *Your_monitor's_name* (DFP-0) (connected) in which case your Display Device Name is DFP-0

Check and if necessary correct xconf: sudo gedit /etc/X11/xorg.conf

Look for a line like:

Option "CustomEDID" "/etc/X11/Shimian_edid.bin"

and edit it to read:

Option "CustomEDID" "DFP-0:/etc/X11/Shimian_edid.bin"

Reboot and at last the monitor works at 2560x1440 as intended.

If that hadn't worked, Plan B was to build a custom configuration following NVidia's Xconfig options (in the README file for the 310.19 Linux driver from NVidia's downloads), in particular the "CustomEDID" option.

Thanks to the contributors to the links above and hopefully this will help someone else with the same problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.