Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I installed x11rdp using the tip here X11RDP Best Remote Desktop on Ubuntu 12.04, its a script that download, build, install and configure x11rdp, I ran once the sudo bash setup.sh, it didn't work because I didn't have the command make so I installed it, the make command ran without trouble except by the package libxcb1-dev, who seems broken, I tried ran apt-get -f install, it didn't work again, I tried update by the update manager, same problem again, I tried use synaptic and didn't work again, any idea to solve that problem or any idea if is something that I have done wrong or that script has done wrong or if its a problem in the package?? by the way, even with the broken package I could install x11rdp with the script and I am using without trouble.

here the LOG:

The following packages have unmet dependencies:
 libxcb1-dev: Depends: libxcb1 (= 1.8.1-1) but 1.8.1-1ubuntu0.1 is installed
Depends: libxau-dev (>= 1:1.0.0-1) but 1:1.0.6-4 is installed
Depends: libxdmcp-dev (>= 1:1.0.0-1) but 1:1.1.0-4 is installed
 ldconfig deferred processing now taking place
and log into the `apt-get -f install`
 Errors were encountered while processing:
  libxcb1-dev
  libx11-dev
  libxfixes-dev
 E: Sub-process /usr/bin/dpkg returned an error code (1)

 A package failed to install.  Trying to recover:

 dpkg: dependency problems prevent configuration of libxcb1-dev:
  libxcb1-dev depends on libxcb1 (= 1.8.1-1); however:
   Version of libxcb1 on system is 1.8.1-1ubuntu0.1.
 dpkg: error processing libxcb1-dev (--configure):
  dependency problems - leaving unconfigured
 dpkg: dependency problems prevent configuration of libx11-dev:
  libx11-dev depends on libxcb1-dev; however:
   Package libxcb1-dev is not configured yet.
 dpkg: error processing libx11-dev (--configure):
  dependency problems - leaving unconfigured
 dpkg: dependency problems prevent configuration of libxfixes-dev:
  libxfixes-dev depends on libx11-dev; however:
   Package libx11-dev is not configured yet.
 dpkg: error processing libxfixes-dev (--configure):
  dependency problems - leaving unconfigured
 Errors were encountered while processing:
  libxcb1-dev
  libx11-dev
  libxfixes-dev
share|improve this question

marked as duplicate by Seth, karel, Avinash Raj, Aditya, mikewhatever Jan 25 at 19:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Install build-essential Install build-essential if you have not done so already. This provides various packages useful for building software in Ubuntu. It can be installed in the Software Center or by running:

sudo apt-get update && sudo apt-get install build-essential
share|improve this answer
    
I don't think this will help. Installing build-essential will just fail when it tries to install make (one of its dependencies). It's worth a try, though. –  Eliah Kagan Feb 4 '13 at 17:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.