Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

l have just installed Ubuntu 12.04 on my machine when l started firefox for the first time on typing google.com l redirected to random websites

l have also tried conneting the computer to a differnt router same problem

Also the same laptop is running Windows 7 with no such issues.

Another thing l have just noticed is it only happens when l type google.com if l type www.google.com the redirection does not occur.

And this is only happening on FireFox l have installed Chrome works with no issues.

share|improve this question
1  
Are you sure you typed google.com? –  Dr_Bunsen Jan 4 '13 at 11:56
    
Yes it has been happening for the past 3 days –  sochdeveloper Jan 4 '13 at 13:57
    
Different DNS settings? –  Dr_Bunsen Jan 4 '13 at 14:00
1  
Have you tried running Firefox in Safe Mode? That'll disable all extensions, so that might help in troubleshooting if an extension is responsible for it (eg., a rogue greasemonkey script). –  nitstorm Jan 5 '13 at 21:34
2  
Please open the file /etc/hosts, copy its contents to the clipboard, and then paste it into your question. (Give it code formatting with the <$> tool so it appears correctly.) Remove anything from it that discloses sensitive information (usually there is nothing, but if you've modified it yourself to include hosts on your own network theoretically there might be some information you wouldn't want to give out). If you do remove anything from it, please make sure to let us know that you did so and where in the file the removals were. –  Eliah Kagan Jan 5 '13 at 22:32

1 Answer 1

I had something similar on 10.04. When Google searching in Firefox, the original results got additional set of "monstermarketplace" and other results not relevant to the search. Other browsers or other OS's were not affected. After disabling google.com scripts with NoScript, the problem disappeared. After removing "SearchBar" extension, I could again allow google.com scripts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.