Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I download emacs with 'sudo apt-get install emacs'. When I run emacs, I see emacs with too big fonts. I don't know why the default setup to have normal font size in emacs. How can I do that? enter image description here

share|improve this question
add comment

2 Answers 2

up vote 19 down vote accepted

The temporary solution

You can press C-x C-+ and C-x C-- to increase or decrease the buffer text size.

The permanent solution

Put the following in your .emacs-file:

 (set-face-attribute 'default nil :height 100)

The value is in 1/10pt, so 100 will give you 10pt, etc.

Source: How to set the font size in emacs?

share|improve this answer
add comment

A slightly different way to do the same thing, by setting botht the font and size in one go, again in the .emacs file. If you want to use a differing font check it exists first or you will get an error message.

(set-default-font "Monospace-12")

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.