Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Sun's Java because of performance issues running Minecraft.

When I try to remove the OpenJDK packages by

sudo apt-get purge openjdk*

however, the JDownloader package is being removed as well. If I try to remove all OpenJDK-7 packages one by one, OpenJDK-6 is being installed instead.

IMHO there should be a way to satisfy JDownloader's dependencies for a Java runtime environment with Sun's version.

Is there any way to keep JDownloader while completely removing the opensource Java versions?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You could let the system remove it and then install it again with the option --no-install-recommends.

That will ignore the necessary dependencies listed on the package and install only the package it self.

More information on that subject here:

share|improve this answer
    
Thanks for your answer! I've tried that, but since openjdk is marked as a dependency, not a recommendation, for JDownloader, this won't work. Upon reinstallation of JDownloader (from this ppa:jd-team/jdownloader), openjdk is being reinstalled as well. –  FuzzyQ Jan 4 '13 at 11:12
    
Then download the package and install it with dpkg --force-depends as suggested on the linked answer. –  Bruno Pereira Jan 4 '13 at 11:18
    
I just tried that by myself and it worked. Again, thank you very much! –  FuzzyQ Jan 4 '13 at 11:21

The real answer here is that that package was buggy, it depended on specific JDKs rather than the generic javaX-runtime virtual packages.

I pointed this out to the maintainer of the PPA, and he's uploaded a new version that depends on default-jre | java6-runtime | java7-runtime. This should be satisfied by the Sun JDK.

share|improve this answer
    
Good work! I've tried to install the ppa version and it's functioning again like it should. Thank you! –  FuzzyQ Jan 12 '13 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.