Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a server running Proxmox (a virtualization platform), and created a KVM virtual machine with Ubuntu Server 12.10. After configuring the network, everything works fine, but if I add a second network adapter to that virtual machine, it is not recognized. dmesg | grep -i eth just shows one interface (eth0).

share|improve this question
add comment

2 Answers

Finally found the solution. Rebooting the machine is not enough, stopping the VM and starting it again is needed.

share|improve this answer
add comment

Load the following kernel modules in the guest to enable hot-plugging of devices in KVM:

modprobe acpiphp
modprobe pci_hotplug

Add them as two separate lines in /etc/modules (without the modprobe part) to enable them permanently. This is Debian/Ubuntu specific as most other distributions (like CentOS/RedHat/Fedora/SUSE) build the kernel with these modules built-in. For Debian/Ubuntu you'll always have to load these modules yourself, unfortunately.

See also (block devices and network devices aren't really much different in this aspect):

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.