Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run Wget from terminal with command

wget targetfile.php

I got error "Scheme Missing". What does it is suppose to mean and how to fix it? I googled but all links I found is speaking of drupal wget. I've tried using absolute path but still not working and yield the same error. I'm trying to set up cronjob here. I follow this tutorial http://www.thesitewizard.com/general/set-cron-job.shtml where then it leads me to use wget.

tried

wget absolutePath/targetfile.php
usr/bin/wget absolutePath/targetfile.php

also tried using relativePath to targetfile.php by changing directory to absolutePath first.

share|improve this question
    
You have to specify path to the file, like a url. –  saji89 Jan 4 '13 at 4:54
    
What do you mean by like url? I tried using absolute path already if that's what you are saying. –  Tendou Kishi Jan 4 '13 at 5:06
    
Can you post the path you tried, without specific ip or domian? –  saji89 Jan 4 '13 at 6:49
    
ok, added to the question. –  Tendou Kishi Jan 4 '13 at 6:54

2 Answers 2

up vote 1 down vote accepted

Use php interpreter instead. So it should be

/usr/bin/php absolutePath/targetfile.php
share|improve this answer

My experience with wget is that you use it to download a file from a webpage directly. I had similar problems when my source webpage no longer existed. A normal wget command usually looks like this, I believe wget http://www.example.com/filename.whatever. This link might be helpful to you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.