Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had been using Synapse and Docky for launching application and finding files.

I really love unity but I am seriously facing problem when I want it to appear quickly and search quickly application and documents for me.

Can any one help me how to optimize it for better performance?
What are the ideal hardware specs for Unity 3D?
Is Canonical serious to make it a polished interface for power users?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

In CCSM, go into the options for Ubuntu Unity Plugin and in the tab Experimental, change option Dash Blur from "Active Blur" to "Static Blur" or "No Blur".

You can also go into option Composite and disable "Detect Refresh Rate" and increase option Refresh Rate to over 60.

Remember these options will only apply with Unity 3D

share|improve this answer
    
Thanks, that did the trick! I left refresh rate to 60. What is refresh rate? –  umpirsky Jan 8 '13 at 20:02
    
@umpirsky sorry for the delayed response, refresh rate is some thing which tries to put display for number of times per second making clear visible with out any minute interruption. I am happy it helped. –  VRU Jan 18 '13 at 12:42
    
Yeah, thanks, the Blur was buggy and slow, and now it's just as it should be, thanks a lot –  Dorian Jun 17 '13 at 6:50

To Speed Up Unity Follow Here (Usually Works For All Distros/A More In Depth Guide):

  1. Open A Terminal Window (Ctrl+T) Or Search Terminal In Unity
  2. Type In The Following:

    sudo apt-get install compizconfig-settings-manager
    
  3. Close Your Terminal

  4. Goto Unity Search And Type In:

     compiz
    
  5. Click Compiz

  6. First Click Opengl Plugin

  7. Take A Screenshot Before You Do Any Changes!!!

  8. Change The Following

    Uncheck Sync To VBlank And Change the Dash Blur To No Blur

    Then See if This Made Unity A bit Faster! If it made unity faster and you are satisfied, Close Compiz

if Not you can try a couple other tweaks

  1. Click back At The Bottom Then Click Composite

  2. Take Another Screenshot

  3. Then Uncheck The Option Detect Refresh Rate

  4. Then Click Back And Go Into Unity

  5. Take Another Screenshot

  6. Then Change The Following Option

    Change: Dash Blur To No Blur

Then Close Compiz

If there was an issue during your installation or you have problems with Unity or anything, Use the screenshots you took to restore your Settings.

Enjoy!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.