Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.10.

When I try setting some shortcuts and restart the System they are "deactivated" or default (but they are still working). After one more restart they do not work any more. Can you tell me how to handle this problem, please?

Thanks a lot!

share|improve this question
    
Please elaborate on how you set them and what you set. –  FEichinger Jan 3 '13 at 17:06
1  
You are probably experiencing this bug: bugs.launchpad.net/ubuntu/+source/compiz/+bug/1063617 –  desgua Jan 8 '13 at 21:39

2 Answers 2

I recommend not using the flat-file. It will nuke your compiz settings so that you have to:

rm ~/.compiz-1 ~/.config/compiz-1

Instead try this workaround:

Custom keyboard shortcuts are reset. How can I make them set permanently?

share|improve this answer

This is what I use as a workaround:
1) Install ccsm
2) Open ccsm 3) Go to "Preferences" and "Export" your settings (save)
4) Go to "Preferences" > "Backend" and set it to "Flat-file configuration Backend".
5) Right click on Desktop and make a New Folder
6) Open the New Folder and navigate to /usr/bin
7) Open gnome-terminal from within the folder
8) Into terminal, run: ccsm
9) Go to "Preferences" and "Import" the settings saved on step "3"
10) Done.

enter image description here

share|improve this answer
    
Doing this seems to remove/clear/destroy all my settings. Not really a solution. –  Ivo van der Wijk Feb 22 at 8:13
    
You will have to restore your previous saved settings. I have changed the answer to explain how to do that. –  desgua Feb 23 at 12:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.