Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a wired network connection from my Ubuntu (10.10) PC (call it PC-A) to a Netgear MR314 router and from there to a Thompson TG585v7 ADSL modem. The only devices connected (by ethernet cable) to the Netgear router are a network printer and the PC in question (PC-A). Connected (by ethernet cable) to the Thompson ADSL modem are two PCs (one Ubuntu 10.10 - call it PC-B, one with OpenFSG- call it PC-C) and the Netgear router as well as some part-time devices on the Wireless connection. So, ignoring wireless, it looks something like this:

        The World via ADSL!
              |
              |
PC-C ------ Modem ------- PC-B
              |
              |
              |
Printer --- Netgear Router --- PC-A

This seems to work without any problems under normal operation.

However, if I try to upload large files from the problem PC (PC-A) to either PC-B or PC-C, the data is transferred for a while, but after around 5 minutes the network connection disconnects briefly. This also sometimes (but less consistently) happens if the transfer is going in the other direction. I've tried the transfers with scp, rsync-over-ssh and plain rsync. All suffer the same problem.

I can tell this has happened as a notification window appears at the top of the screen saying "Wired network. Disconnected: you are now offline" and a few seconds later a notification window appears saying "Auto eth0. Connection Established" and the network works again. Unfortunately, this results in the transfer stalling and not necessarily being recoverable (depending on the type of transfer).

I can consistently transfer files by scp or rsync between PC-C and PC-B (in either direction) without any problems at all and I've never noticed having problems downloading large files from the web onto PC-A.

In a quick test I just performed, I opened a terminal on PC-A and tried to scp a 700MB file from PC-B to PC-A and the connection dropped after 200MB. I then opened Google Chrome and downloaded a 693MB file from the web and the connection didn't drop at all.

When the connection drops, /var/log/messages shows this:

Jan 27 19:37:58 morat kernel: [ 4065.023469] e1000e: eth0 NIC Link is Down
Jan 27 19:38:07 morat kernel: [ 4074.083848] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX
Jan 27 19:38:07 morat kernel: [ 4074.083852] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO

The time between "NIC Link is Down" and "NIC Link is Up" seems to be consistently 9 seconds.

I'm thoroughly confused. I probably haven't provided enough information to get to the bottom of this, so if there's anything else that would be useful, please say in the comments or wherever and I'll add whatever detail I can.

Thanks in advance for any help you can offer.

share|improve this question

closed as too localized by Marco Ceppi Jan 24 '12 at 16:03

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I would look in the logs of your Netgear router for more information. –  Lekensteyn Jan 27 '11 at 20:14
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Jan 24 '12 at 14:12

1 Answer 1

If you have multiple devices connected to the modem, then I assume it has a built in router, so you have a router daisy chained into another router, which is a weird configuration. For this to work they need to be on different subnets, so, for example, PC-A would be 192.168.0.1 and PC-B would be 192.168.1.1.

If you are loosing the ethernet link to the router, then it sounds like it is crashing and rebooting. Try getting rid of it and just plug PC-A into the modem directly.

If you don't have enough ports on the modem then you also might try disabling the routing functions of the netgear and leaving the WAN port on it unused so you don't have two separate subnets.

share|improve this answer
    
Sorry, I should have clarified: PC-A and the printer are on 192.168.3.* and PC-B etc are on 192.168.1.*. The reason for the second router is that the link between modem and router is between two floors of the building and I had a router (and didn't have a switch) and didn't want to run two cables upstairs. I'll have a look to see whether the routing functions of the Netgear can be disabled. –  DrAl Jan 27 '11 at 21:35
    
Just don't use the WAN port to connect it to the other router and that will bypass the router and only use the switch. Also for testing purposes, just drop the printer and router and connect the PC to the line running downstairs. –  psusi Jan 28 '11 at 15:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.