Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 12.10. I installed the xubuntu-desktop package to see if I would like it and determined I would prefer to keep using unity. Ever since I did that I've been running into certain issues when using unity. I never had a screensaver before, but now there is one and I can't seem to turn it off or configure it from the settings menu.

Coming back from the screen saver also results in a compiz error message sometimes. I also have a new update notification icon as mentioned in this related question.

How do I turn off the screensaver? I'd like to remove the package completely if I could.

share|improve this question

2 Answers 2

There are screensaver settings also in x-system. You can use terminal to turn screensaver/blanking off by command: xset s 0 0 (times in seconds, 0 means off) and you can turn power management off by command: xset -dpms and on by xset +dpms

Default setting for saver are:xset s 600 600 (=10 minutes as you may have noticed).

If you remove or replace xscreensaver or gnome-screensaver these setting can still turn you display off. You may want to look the curret settings by command: xset q

share|improve this answer

Run the following command in the terminal:

sudo apt-get remove xscreensaver
share|improve this answer
    
Do I have to manually remove all the extra things xubuntu-desktop installed now? Seems like apt-get remove --purge xubuntu-desktop didn't touch its dependencies. –  Blitzkev Jan 3 '13 at 16:11
    
@Blitzkev Did removing xscreensaver work? Yes, you have to manually remove the extra things because xubuntu-desktop is just a meta package. Solutions here: askubuntu.com/search?q=remove+xubuntu –  functionptr Jan 3 '13 at 20:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.