Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using findsmb on my home network gives me this:

IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION 
---------------------------------------------------------------------
192.168.1.3     MINI           [MSHOME] [Unix] [Samba 3.0.25b-apple]
192.168.1.9     SERVER        +[    MSHOME        ]
192.168.1.11    NAS            [    WORKGROUP     ]
  • MINI - a Mac mini
  • SERVER - Ubuntu 10.10 server; Samba installed but not running.
  • NAS - another Ubuntu 10.10 server; Samba installed but not running.

When Samba is running the Ubuntu groups are the values from /etc/samba/smb.conf, but with Samba turned off it falls back to these defaults - even different defaults for two installations of the same OS.

I would like to change the workgroups, but I can't figure out where the value is coming from: Not from Samba (that's a different value), not from Winbind (not running), not from Avahi (not installed); and I don't know of anything else involved in network groups.

How can I find this setting so I can change it?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Your workground name comes from the NetBIOS Name server which is running on your Ubuntu machines. It's shipped with Samba.

You can change the workgroup name in samba configuration /etc/samba/smb.conf and then restart the NetBIOS server using init:

sudo service nmbd restart

You can also remove this service from running, but check the Samba documentation about what it does and if you need it:

http://www.samba.org/samba/docs/man/manpages-3/nmbd.8.html

share|improve this answer
    
I know, I turned it on in OS X to share files between Mac and Ubuntu. Turning it off makes the OS X share disappear from the findsmb listing, as expected. –  j-g-faustus Jan 27 '11 at 22:01
    
OK, found which Ubuntu service the workgroup name is coming from: nmbd - stopping nmbd makes the computer disappear from the list, and restarting it gave me the workgroup name I expected. I think the issue is solved. –  j-g-faustus Jan 27 '11 at 22:49
    
Thanks j-g-faustus, I've updated my answer so the next person who searches and finds this question will know what to do. –  Martin Owens -doctormo- Jan 28 '11 at 1:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.