Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently installed Kubuntu 12.10 on a Dell XPS system. Overall happy, but I cannot access my Windows printers. Samba is correctly installed and works for browsing and accessing Windows directories on the MSHOME workgroup.

When trying to add my existing (and working) printers to Kubuntu, I select the "Windows Printer via SAMBA" option and the "browse" box on the right is not available (gray). When entering the printer name directly, as soon as I have entered "smb://MSHOME/x", "x" being just about anything, the "next" button at the bottom is available and enables me to select a printer. which of course will not work! (no correct Windows server or printer is selected).

I tried just about all options, including providing proper authentication data but nothing seems to enable the "browse" box to become active.

Sounds to me like a bug in the add printer feature, no?

Note: Entering the exact path to the printer enables to select, enable and print, but it may not be easy in a larger network environment.

Thanks, -Patrick

share|improve this question
add comment

2 Answers 2

Install python-smbc (SMB client) and try again.

share|improve this answer
add comment

got the very same problem here with both kubuntu 12.10 and mint 14 KDE

I found a (quite improvised) way to tweak it by installing system-config-printer-gnome (just go to Muon package manager and search for it) then running "system-config-printer" from the terminal: you'll have network printer browsing just as you have in ubuntu... after installing it from here you'll find your network printer perfectly installed when checking back to system config>printers

by the way, when you're done with installation you can remove the system-config-printer-gnome package without affecting your new settings (that's because it's just a tool to work on CUPS in a simple graphic way)

hope it could help

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.