Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony VAIO S series with Windows 8 preinstalled, and I installed Ubuntu 12.10 on a new partition. When the PC boots Grub is display, and I can choose between Windows 8 (didn't worked at the beginning, had to change Grub settings) and Ubuntu 12.10. When I select Ubuntu 12.10 everything is OK, but when I use Windows 8, and I restart Grub isn't displayed anymore (Windows 8 boots immediately).

I booted a Ubuntu 12.10 LiveUSB, used efibootmgr, and found out that Windows 8 (each time it boots) changes EFI default bootloader from Grub to Windows Boot Manager.

How do I change this in Windows 8? I read something about bcdedit, but it does not work or I don't know how to use it...

share|improve this question
    
I think you're on a good way solving this yourself. Just keep digging [; –  Melon Jan 3 '13 at 11:11
3  
Yep I just need one little thing then I'll write a tutorial how to do it. Microsoft sucks why do they have to change the default boot manager? In my opinion it's to prevent people from using anything else then Microsoft products. –  Kouros Jan 4 '13 at 5:21
    
Naaah, I think that they just don't care that's. Anyway, hope to see your tutorial soon. –  Melon Jan 4 '13 at 9:57
    
I just asked Microsoft's customer service about this, and they directed me to their forums. On the forums a fella told me the windows puts itself on the first place. Period. If I don't like it, just create a batch file in windows that runs at every startup end bcdedt-s the windows uefi config to boot grub first next time. Nice. –  netom Jan 7 '13 at 9:30
    
The GPT file system contains a duplicate of the boot sectors. It seems Windows is just checking the MBR checksum and 'repairing' it by overwriting it with the original protective MBR data. A security best practice. en.wikipedia.org/wiki/GUID_Partition_Table –  just sayin Apr 23 at 14:04

5 Answers 5

up vote 14 down vote accepted

I can make no promises, but try this from a Windows Command Prompt window launched with Administrator privileges:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Note that {bootmgr} should be typed exactly; that's not a variable. If that doesn't work, you could try this in Linux:

  1. Back up the entire contents of /boot/efi (your EFI System Partition, or ESP).
  2. Type sudo mv /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi /boot/efi/EFI/Microsoft.
  3. Type cp /boot/efi/EFI/ubuntu/grubx64.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi.
  4. Create a new /etc/grub.d/40_custom file entry that refers to EFI/Microsoft/bootmgfw.efi. Model it after the existing entry in /boot/grub/grub.cfg that refers to EFI/Microsoft/Boot/bootmgfw.efi; just remove Boot from the boot path and give the entry a new name.
  5. Type sudo update-grub to install the new GRUB entry.

When you reboot, GRUB should come up. The trouble is that if/when Windows decides to re-install its boot loader, the system will start booting straight to Windows again.

For step 4, you can:

  1. Copy the 40_custom entry beginning with menuentry 'Windows ...' situated between a set of ### BEGIN <path> ### and ### END <path> ### tags/comments. This is the entry having the path containing Boot.
  2. Create a new entry in file /etc/grub.d/40_custom by adding the copied menuentry.
  3. Change the name of the new entry (original should be Windows Boot Manager or something similar).
  4. Change the path from EFI/Microsoft/Boot/bootmgfw.efi to EFI/Microsoft/bootmgfw.efi.
share|improve this answer
2  
Would you consider doing me/us a favor and give us the specific terminal prompts for step 4? I did everything else except that step because I wasn't sure exactly what commands to type in. Grub now works, but it won't let me boot into Windows. Eek! –  user280151 May 10 at 14:34
  1. run Boot-Repair's Recommended Repair from liveCD, then reboot the pc.
  2. if still not good, run Boot-Repair --> Advanced options --> untick "Backup and rename EFI files" --> tick "Restore EFI backups" --> Apply
share|improve this answer
1  
Nop problems come from Windows 8 –  Kouros Jan 7 '13 at 20:05

I have only a part of an answer: a working solution that is almost ok until I find out how to fix it permanently.

Had the same problem: thinkpad edge shipped with windows 8; installed ubuntu as dual boot and mostly forgot about windows until 8.1 came out and I thought I'd give it a try before deleting windows for good. So after installing 8.1, grub doesn't appear any more on startup BUT when I press F12 then a different menu appears which allows me to boot ubuntu. That's how I start my computer now: but every second time I forget to press F12 and it still starts Windows (which I almost never want).

So pressing F12 helps for a while (not sure if this works in your case but it may be worth a try). I know there are instructions about how to restore grub but I won't do anything before I'm completely sure.

share|improve this answer

Somehow Windows 8.1 is Completely Blocking Ubuntu is a duplicate of this question. I don't think it is but I can only comment here. I experienced the same symptoms as Windows 8.1 is Completely Blocking Ubuntu.

In my case the solution was to press F2 during bootup and change the order of booting so that ubuntu was top of the list. For some reason after I upgraded my dualboot (Win/ubuntu) laptop from Win 8 to Win 8.1 'windows' appeared at the top of the boot list ahead of ubuntu, DVD, USB, etc and my laptop booted straight into Windows 8.1 without giving me any choice.

Pressing F2 during bootup and making ubuntu top the list solved my problem and made ubuntu reachable again (along with Windows 8.1) after I upgraded to Windows 8.1 from the Microsoft store.

share|improve this answer

How do I change this in Windows 8? I read something about bcdedit, but it does not work or I >don't know how to use it...

Same issue here, I finally figured out that this latest W8.1 update did that, and I know that because I just updated today and haven't for 33 days or so my HP Pavilion told me..

Anyhow, here is what worked:

I followed this Utube video to stop 'Automatic [Boot] Repair': http://www.youtube.com/watch?v=VRQYmtysFkg

Then changed the bootmgr using the above solution supplied by Rod: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Bingo!

btw: Boot Repair from my LiveUsb did nada but cause a short flash while W8 repaired its boot entry..

share|improve this answer
    
Its great that you have decided to help! But your answer does not provide any context for the (video)link you posted and we here at Ask Ubuntu want it. We want the answers here to provide contexts as (video)links may be dead sooner or later. –  Venki Jun 14 at 2:00

protected by Community Aug 24 at 20:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.