Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After Fresh Installation of Ubuntu 12.04.1 x64, When I launched Ubuntu One I got following Error.

enter image description here

When I tried to upgrade python-ubuntuone-control-panel , It shows that already newest version. I reinstalled Ubuntu one but got same.

Error While installing using Terminal

kk@kk:~$ sudo apt-get install  ubuntuone-client 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntuone-client : Depends: python-ubuntuone-client (= 3.0.0-0ubuntu1) but 3.0.2-0ubuntu1 is to be installed
                    Recommends: ubuntu-sso-client-gui (>= 2.99.91)
E: Unable to correct problems, you have held broken packages.
kk@kk:~$ 

But when I tries to

kk@kk:~$ sudo apt-get install -f 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Edit

enter image description here

but when I see synaptic I have already installed libnautilus to 1:3.4.2.

share|improve this question
    
It seems like your apt cache is broken. Are there any errors when you do apt-get update? What is the output of apt-cache policy ubuntuone*? –  dobey Jan 3 '13 at 18:41
add comment

1 Answer

Try running:

sudo apt-get -f install

It might autocorrect some dependency issues. If it does not work, try removing Ubuntu One and reinstall it.

Edit:

It seems that you have a wrong package version of the package python-ubuntone-control-panel. Go into your software sources, go to third tab (Updates) and make sure that the second checkbox (recommend updates (precise-updates)) is checked. Then go out and run

sudo apt-get update
sudo apt-get upgrade

Your version of Ubuntu One should now be updated from 3.0.0 to 3.0.2, which fits with the package python-ubuntuone-control-panel 3.0.1 that you already have installed.

Alternative

If this does not work, then you might try to go to Synaptic and look for ubuntuone-control-panel and make sure that it has not been held back at some version. If it has a green checkbox in the left column in the result list, you are fine.

Then try to use aptitude to install the package. It is generally better at solving dependencies

sudo aptitude install ubuntuone-client

Edit 2

Regarding your last edit you write it seems that you have installed the package ubuntuone-gnome-client which is not necessary for Ubuntu One running in Unity (clean install of Ubuntu 12.04.1). This package can safely be removed:

sudo apt-get remove ubuntuone-client-gnome
share|improve this answer
    
Tried Before you answered. also Tried to reinstall Ubuntu one. –  K.K Patel Jan 3 '13 at 12:29
    
still no success.. –  K.K Patel Jan 3 '13 at 13:25
    
Have you tried with aptitude? Alternatively you could try to Go to ubuntuone-control-panel in Synaptic and force version 3.0.0 or remove it and download it from the Ubuntu archive. If you want, we can take this to a chat room. –  Zilvador Jan 3 '13 at 17:19
    
Thanks a lot friend. With using synaptic I solved issue most of. But I am getting now a just a little problem. see edited question –  K.K Patel Jan 4 '13 at 3:31
    
Please tell me what you did in Synaptic to solve the issue to help other users. And have a look at the last line of the edited answer. Also, have you tried running aptitude? It will give suggestions to unresolved package dependencies. –  Zilvador Jan 4 '13 at 10:37
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.