Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I minimal installed my OS, but got an unexpected error while setting my monitor resolution. it seems like a very old problem, but this time there are something else(I think).

  1. to install the desktop environment: apt-get update, apt-get install xorg-core xserver-xorg-core gnome-core gdm3
  2. to install graphic grivers apt-get install build-essential nvidia-kernel-common linux-headers-$(uname -r), ./NVIDIA-Linux-x86_64-304.64.run steps above seems all things are in the correctly way.

  3. to set resolution : cvt 1440 900, xrandr --newmode xxx, xrandr --addmode VGA-0 xxx

then I got that error:

X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 153 (RANDR). Minor opcode of failed request: 18 (RRAddOutputMode). Serial number of failed request: 29. Current serial number in output stream: 30.

I don't know what information U need, and just list some

graphic card model: nvidia gt630.

graphic card's memory size: 512M ddr5.

monitor: phlips 190cw(1440x900, works well on windows). this is my settings in windows (I haven't install the monitor driver and windows just recogniez it as 190g6)

enter image description here


xrandr out put

Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
  1440x900_60.00 (0x29f)  106.5MHz
        h: width  1440 start 1528 end 1672 total 1904 skew    0 clock   55.9KHz
        v: height  900 start  903 end  909 total  934           clock   59.9Hz

lshw -c video out put

*-display               
   description: VGA compatible controller
   product: nVidia Corporation
   vendor: nVidia Corporation
   physical id: 0
   bus info: pci@0000:05:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:16 memory:f6000000-f6ffffff memory:e0000000-efffffff(prefetchable) memory:f0000000-f1ffffff(prefetchable) ioport:d000(size=128) memory:f7000000-f707ffff(prefetchable)

xorg.conf

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I trid to get edid: apt-get install read-edid, sudo get-edid | parse-edid

but got this error:

get-edid: get-edid version 2.0.0

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
    Function supported
    Call successful

    VBE version 300
    VBE string at 0x11100 "NVIDIA"

VBE/DDC service about to be called
    Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
    Function supported
    Call successful

    Monitor and video card combination does not support DDC1 transfers
    Monitor and video card combination does not support DDC2 transfers
    0 seconds per 128 byte EDID block transfer
    Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
    Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
    Function supported
    Call failed

The EDID data should not be trusted as the VBE call failed
Error: output block unchanged

I tried to force the resolution to 1440x900 by using nvidia-settings, after reboot, resolution changed to 1440X1024(nvidia-settings added a line to xorg.conf Option "metamodes" "1440x1024 +0+0"). screen become horizon-scrollable like that:

enter image description here

I also tried to extract edid.bin(by using nvidia-settings) and add Option "CustomEDID" "DFP-1:/etc/X11/edid.bin" at Section "Device" to xorg.conf. thanks to the awesome post Fixing Ugly DVI/HDMI Displays due to EDID bugs on nVidia drivers, but unfortunately it doesn't work either.


update: var/log/Xorg.0.log

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.0.0-1-amd64 x86_64 Debian
Current Operating System: Linux xx 2.6.32-5-amd64 #1 SMP Sun Sep 23 10:07:46 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-amd64 root=UUID=df3ea9ad-faaf-4918-a213-5a673080e935 ro quiet
Build Date: 29 October 2011  06:58:14PM
xorg-server 2:1.7.7-14 (Julien Cristau <jcristau@debian.org>) 
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan  8 23:09:08 2013
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(**) Option "Xinerama" "0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType".
Entry deleted from font path.
(Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType").
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(II) Loader magic: 0x7c8a40
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 6.0
X.Org XInput driver : 7.0
X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:5:0:0) 10de:0f00:0000:0000 nVidia Corporation rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
(II) Open ACPI successful (/var/run/acpid.socket)
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module  304.64  Tue Oct 30 11:18:32 PDT 2012
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  304.64  Tue Oct 30 10:59:51 PDT 2012
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 05@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "CustomEDID" "DFP-0:/home/teifi/edid.bin"
(**) Jan 08 23:09:09 NVIDIA(0): Enabling 2D acceleration
(II) Jan 08 23:09:10 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:09:10 NVIDIA(GPU-0):     Vision stereo.
(II) Jan 08 23:09:10 NVIDIA(0): NVIDIA GPU GeForce GT 630 (GF108) at PCI:5:0:0 (GPU-0)
(--) Jan 08 23:09:10 NVIDIA(0): Memory: 1048576 kBytes
(--) Jan 08 23:09:10 NVIDIA(0): VideoBIOS: 70.08.aa.00.00
(II) Jan 08 23:09:10 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Jan 08 23:09:10 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Jan 08 23:09:10 NVIDIA(0): Valid display device(s) on GeForce GT 630 at PCI:5:0:0
(--) Jan 08 23:09:10 NVIDIA(0):     CRT-0
(--) Jan 08 23:09:10 NVIDIA(0):     Philips 190G6 (CRT-1) (connected)
(--) Jan 08 23:09:10 NVIDIA(0):     DFP-0
(--) Jan 08 23:09:10 NVIDIA(0):     DFP-1
(--) Jan 08 23:09:10 NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(--) Jan 08 23:09:10 NVIDIA(0): Philips 190G6 (CRT-1): 480.0 MHz maximum pixel clock
(--) Jan 08 23:09:10 NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
(--) Jan 08 23:09:10 NVIDIA(0): DFP-0: Internal Single Link TMDS
(--) Jan 08 23:09:10 NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
(--) Jan 08 23:09:10 NVIDIA(0): DFP-1: Internal Single Link TMDS
(**) Jan 08 23:09:10 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:09:10 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:09:10 NVIDIA(0):     been enabled on all display devices.)
(WW) Jan 08 23:09:10 NVIDIA(0): No valid modes for "CRT-1:1440x900"; removing.
(WW) Jan 08 23:09:10 NVIDIA(0): No valid modes for "CRT-1:1280x800"; removing.
(II) Jan 08 23:09:10 NVIDIA(0): Validated MetaModes:
(II) Jan 08 23:09:10 NVIDIA(0):     "CRT-1:1024x768"
(II) Jan 08 23:09:10 NVIDIA(0):     "CRT-1:800x600"
(II) Jan 08 23:09:10 NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) Jan 08 23:09:10 NVIDIA(0): DPI set to (68, 65); computed from "UseEdidDpi" X config
(--) Jan 08 23:09:10 NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) Jan 08 23:09:10 NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
(II) Jan 08 23:09:10 NVIDIA:     access.
(II) Jan 08 23:09:10 NVIDIA(0): Setting mode "CRT-1:1024x768"
(II) Loading extension NV-GLX
(==) NVIDIA(0): Disabling shared memory pixmaps
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(WW) NVIDIA(0): Option "TwinView" is not used
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
SELinux: Disabled on system, not enabling in X server
(II) Initializing extension GLX
(II) config/udev: Adding input device Power Button (/dev/input/event4)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.7.6.901, module version = 2.3.2
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 7.0
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event4"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "us"
(II) config/udev: Adding input device Power Button (/dev/input/event3)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event3"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "us"
(II) config/udev: Adding input device USB Optical Mouse (/dev/input/event2)
(**) USB Optical Mouse: Applying InputClass "evdev pointer catchall"
(**) USB Optical Mouse: always reports core events
(**) USB Optical Mouse: Device: "/dev/input/event2"
(II) USB Optical Mouse: Found 3 mouse buttons
(II) USB Optical Mouse: Found scroll wheel(s)
(II) USB Optical Mouse: Found relative axes
(II) USB Optical Mouse: Found x and y relative axes
(II) USB Optical Mouse: Configuring as mouse
(**) USB Optical Mouse: YAxisMapping: buttons 4 and 5
(**) USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Optical Mouse" (type: MOUSE)
(II) USB Optical Mouse: initialized for relative axes.
(II) config/udev: Adding input device USB Optical Mouse (/dev/input/mouse1)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event1)
(**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "us"
(II) config/udev: Adding input device PC Speaker (/dev/input/event5)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/event0)
(**) Macintosh mouse button emulation: Applying InputClass "evdev pointer catchall"
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/mouse0)
(II) No input driver/identifier specified (ignoring)
(II) Jan 08 23:09:12 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:09:12 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:09:12 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:09:12 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:09:12 NVIDIA(0):     been enabled on all display devices.)
(II) Jan 08 23:09:12 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:09:12 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:09:12 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:09:12 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:09:12 NVIDIA(0):     been enabled on all display devices.)
(II) Jan 08 23:09:12 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:09:12 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:09:12 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:09:12 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:09:12 NVIDIA(0):     been enabled on all display devices.)
(II) Jan 08 23:09:59 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:09:59 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:09:59 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:09:59 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:09:59 NVIDIA(0):     been enabled on all display devices.)
(II) Jan 08 23:10:00 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:10:00 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:10:00 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:10:00 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:10:00 NVIDIA(0):     been enabled on all display devices.)
(II) Jan 08 23:10:00 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:10:00 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:10:00 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:10:00 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:10:00 NVIDIA(0):     been enabled on all display devices.)
(II) Jan 08 23:10:00 NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1280x1024 +0+0"
(II) Jan 08 23:10:01 NVIDIA(GPU-0): Display (Philips 190G6 (CRT-1)) does not support NVIDIA 3D
(II) Jan 08 23:10:01 NVIDIA(GPU-0):     Vision stereo.
(**) Jan 08 23:10:01 NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
(**) Jan 08 23:10:01 NVIDIA(0):     device Philips 190G6 (CRT-1) (Using EDID frequencies has
(**) Jan 08 23:10:01 NVIDIA(0):     been enabled on all display devices.)

Any help is greatly appreciated. Thank you

share|improve this question
1  
I can't believe that am can force the resolution to 1440X900 in windows but linux can't. sorry for bad English. –  Teifi Jan 8 '13 at 0:37
    
(1) What is the model of your video card and how much memory it has? (2) In windows when doing 1440x900, are you using 24bit color or 16bit? –  John Siu Jan 8 '13 at 4:51
    
@John Siu sorry for the late response. am updated the question.(1) it's gt630 with 512M ddr5 memory.(2)using 32bit color in windos. –  Teifi Jan 8 '13 at 13:20
    
Post your /var/log/Xorg.0.log, maybe use pastebin.com as it is quite long. –  John Siu Jan 8 '13 at 14:59
    
@John Siu can't open pastebin.com, so I updated the question. –  Teifi Jan 8 '13 at 15:30
show 4 more comments

2 Answers 2

Method 1 - Clear the xorg.conf

Try remove /etc/X11/xorg.conf, restart your x window, and try setting the resolution with nvidia-settings again. Usually the auto-detect work perfectly with DVI cable. But I cannot find the monitor spec online so I am not sure if it has DVI connector.

Method 2 - xorg.org modes line

Try adding the Modes line in Screen section

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes    "1440x900" "1280x800" "1024x768" "800x600"
    EndSubSection
EndSection

Additional

Update X Window and Nvidia Driver

Your version

X Window version

X.Org X Server 1.7.7
Release Date: 2010-05-04

(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 6.0
X.Org XInput driver : 7.0
X.Org Server Extension : 2.0

Ubuntu 12.04

X.Org X Server 1.11.3
Release Date: 2011-12-16

[ 79635.469] (II) Module ABI versions:
[ 79635.469]     X.Org ANSI C Emulation: 0.4
[ 79635.469]     X.Org Video Driver: 11.0
[ 79635.469]     X.Org XInput driver : 16.0
[ 79635.469]     X.Org Server Extension : 6.0

Current Nvidia driver here.

xorg.conf Monitor section (Source)

Section "Monitor"
    Identifier "monitor0"
    VendorName "Plug'n Play"
    ModelName "Philips 190CW"
    HorizSync 30-83
    VertRefresh 55-75

    # Monitor preferred modeline (59.9 Hz vsync, 55.9 kHz hsync, ratio 16/10, 91 dpi)
    ModeLine "1440x900" 106.5 1440 1520 1672 1904 900 903 909 934 +hsync -vsync

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_120"  229.75  1440 1552 1712 1984  900 901 904 965  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_100"  187.55  1440 1544 1704 1968  900 901 904 953  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_85"  156.79  1440 1536 1696 1952  900 901 904 945  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_75"  136.49  1440 1536 1688 1936  900 901 904 940  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_60"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1440x900_50"  87.41  1440 1512 1664 1888  900 901 904 926  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_120"  181.21  1280 1376 1520 1760  800 801 804 858  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_100"  147.89  1280 1376 1512 1744  800 801 804 848  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_85"  123.38  1280 1368 1504 1728  800 801 804 840  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_75"  107.21  1280 1360 1496 1712  800 801 804 835  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_60"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync

    # modeline generated by gtf(1) [handled by XFdrake]
    ModeLine "1280x800_50"  68.56  1280 1336 1472 1664  800 801 804 824  -HSync +Vsync
EndSection
share|improve this answer
    
I've tested just now, but method 1 and 2 doesn't work for me... bad news this monitor desn't have a DVI cable too.. please, is there any other way to config the resolution? I'm scratching my hair and feeling frustrated... –  Teifi Jan 8 '13 at 13:30
    
I'll try it, not now but after work. Am hope it works well for me, if so, the bounty is yours :) –  Teifi Jan 9 '13 at 0:39
    
It is a bit strange you have a new kernel 3.x but such an old X11 package. Maybe you can consider doing apt-get update; apt-get dist-upgrade to refresh all your packages. –  John Siu Jan 9 '13 at 2:06
    
Any progress or still the same? –  John Siu Jan 13 '13 at 2:15
    
sorry, it can't work... if am detect another minitor, the other resolution is '1440x900', this very strange. –  Teifi Jan 13 '13 at 15:16
show 16 more comments

I had this "BadMatch" problem:

 X Error of failed request:  BadMatch (invalid parameter attributes)
   Major opcode of failed request:  140 (RANDR)
   Minor opcode of failed request:  18 (RRAddOutputMode)
   Serial number of failed request:  27
   Current serial number in output stream:  28

And solved it by editing xorg.conf manually. Add or correction this line in this monitor section:

HorizSync  30-82
VertRefresh  56-76

Save, restart and voila. Resolution is ok. I supposed that problem was there because I used a D-sub to DVI adapter. The display had a D-Sub connector, while the card was DVI. The problem was only on the closed-source nVidia driver; Nouveau was OK.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.