Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the Ubuntu QML toolkit. I've installed Qt5 successfully, but I'm failing on the QML toolkit.

Below is the error information:

W: Failed to fetch http://ppa.launchpad.net/ui-toolkit/ppa/ubuntu/dists/precise/main/source/Sources  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/ui-toolkit/ppa/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

I'd appreciate some help on this as I really want to join Ubuntu Mobile.

share|improve this question
    
I answered a question that also covers this one askubuntu.com/questions/236012/… –  kicsyromy Jan 5 '13 at 16:46
1  
12.04 support is now available: developer.ubuntu.com/get-started/gomobile –  Jorge Castro Jan 16 '13 at 21:37
add comment

closed as too localized by Jorge Castro, gertvdijk, Eric Carvalho, qbi, LnxSlck Jan 17 '13 at 11:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

If you are on Ubuntu 12.04 I had the same problem and followed the instructions here:

http://dragly.org/2013/01/03/getting-started-with-ubuntu-for-phones-on-12-04/comment-page-1/#comment-5821

The issue is they only have packages for Quantal and not Precise so this fix works as well while still getting updates.

Replace precise with your version of ubuntu.:

sudo add-apt-repository ppa:ui-toolkit/ppa
sudo sed -i 's/precise/quantal/g' /etc/apt/sources.list.d/ui-toolkit-ppa-precise.list
sudo apt-get update && sudo apt-get install qt-components-ubuntu qt-components-ubuntu-demos qt-components-ubuntu-examples qt-components-ubuntu-doc notepad-qml

Basically you can download the packages directly meant for 12.10 and use them on 12.04

share|improve this answer
    
People were having errors with the solution, because of the curly quotes in the sed command. Fixed in rev.3. –  gertvdijk Jan 6 '13 at 18:19
add comment

manually install each deb from launchpad https://launchpad.net/~ui-toolkit/+archive/ppa for the UI toolkit (things you need)

share|improve this answer
add comment

From: http://ubuntuforums.org/showthread.php?t=2100758

The issue is they only have packages for Quantal and not Precise.

Replace precise with your version of ubuntu. This will work without installing with dpkg so you will receive updates:

sudo add-apt-repository ppa:ui-toolkit/ppa sudo sed -i 's/precise/quantal/g' /etc/apt/sources.list.d/ui-toolkit-ppa-precise.list sudo apt-get update && sudo apt-get install qt-components-ubuntu qt-components-ubuntu-demos qt-components-ubuntu-examples qt-components-ubuntu-doc notepad-qml

Failed to execute this command. The right command is this:

sudo add-apt-repository ppa:ui-toolkit/ppa && sudo sed -i 's/precise/quantal/g' /etc/apt/sources.list.d/ui-toolkit-ppa-precise.list && sudo apt-get update && sudo apt-get install qt-components-ubuntu qt-components-ubuntu-demos qt-components-ubuntu-examples qt-components-ubuntu-doc notepad-qml

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.