Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I performed an in-place upgrade from 12.04 to 12.10 by following the system update prompts. When I attempted to log in from an NX client (No Machine), my XFCE session was missing fonts almost everywhere, and some of the windowing elements were either missing or drawn incompletely. It was like this with XFCE and Unity, but less so with KDE.

The only way I could get the NX client to display all of the text and draw the GUI elements properly was to select the option Disable the render extension in the NX client options.

I tried reconfiguring the X server dpkg-reconfigure xorg, switching video drivers (from open to NVIDIA), switching window managers, disabling font aliasing. . . . Never got it to work again without disabling the render extension in the NX client.

Any idea what might have changed in the upgrade that would break my NX client settings?

Looking to see if this is related:

GTK unthemed and ugly over NX

Yes! Looks like the same problem:

nomachine NX: Text missing on all gtk interface (Unity and Gnome Classic)

Found a decent (so far) workaround that involves downgrading libcairo2:

http://ubuntuforums.org/showthread.php?t=2081746

I guess that will have to suffice until there is a libcairo fix.

BTW, disabling the render extension via NX client config wasn't working for me because the degradation in quality made illegible some of what text did appear.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I am the one that asked nomachine NX: Text missing on all gtk interface (Unity and Gnome Classic)

I have found a .... new solution?

http://www.nomachine.com/preview/download-package.php?Prod_Id=14

I am guessing that's nomachine's next version of their server/player. I tried the player preview with my my existing nomachine nx server setup, without upgrading the nx server. It seems to work. I am not sure if it is disabling the render extension, but at least there is no major slow down like before.

share|improve this answer

Thanks to this post I found an alternative to the NoMachine client which is literally a drop-in replacement (it even copies across your saved sessions). It's called OpenNX and even better, it's open-source! It shouldn't have the performance/legibility hit that the workaround above does either.

Hopefully this will help anyone else struggling with font rendering issues on 12.10 this seems like a much more "workable" workaround (and doesn't require messing with Ubuntu). Especially with the Windows version of the client which doesn't have the Disable the render extension option that the Linux client does.

share|improve this answer

BTW, disabling the render extension via NX client config wasn't working for me because the degradation in quality made illegible some of what text did appear.

I'm on MATE, and tweaking the font settings in System->Preferences->Appearances helped with make unreadable text more readable. It's still not as crisp as I'd like, but I've seen worse.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.