Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  • I purchased a static IP address from my ISP
  • I am running ubuntu server 12.04 x64 with webmin installed
  • I want to point a purchased domain name (and also a free .tk domain) at my server.

Every time I type the name of my free .tk name, I get the login page for my router. If it is my settings in bind can someone tell me the correct way to setup bind?

If it needs to be set in ubuntu can someone help configure it correctly?

share|improve this question
add comment

4 Answers 4

You need to setup port forwarding on the http port (tcp port 80) to whatever private IP is assigned to your webserver.

The manual for your router/gateway combo is located here: http://www.arrisi.com/support/documentation/user_guides/_docs/WTM652_User_Guide_Std1-1.pdf

In the manual they don't refer to it as port forwarding, rather as virtual servers on page 44. There is a section about adding a well known service there which should apply to http.

Also, ensure that your ISP isn't blocking port 80 (I assume they aren't since you purchased a static IP and thus most likely have business class internet).

share|improve this answer
add comment

Seems that you just need to do the following... 1. Adjust the default port for the router's config pages. 2. Forward port 80 to the statically assigned IP address of your web server. 3. Ensure that your ISP isn't blocking port 80 (many do, try www.canyouseeme.org)

share|improve this answer
add comment

This seems to be a fairly typical routing issue that people run into. When you're inside a NAT network, the router won't send your traffic through the port forwarding routing table. That is to say, if you request the public IP, you'll see the router, not the forwarded server.

If it's any consolation, it sounds like your DNS is fine.

There are at least two solutions:

  • Have an internal DNS server that points to the private IP of the server (eg 192.168.0.56), either running on an internal DNS server, or just munged into each client's /etc/hosts file.

  • Fix the routing table on the router. Most Home/SMB routers won't allow you to do this and it's so variable when it is possible that I've no idea what to advise.

There are actually a few dozen "routing options" but unless you're at the end of a network engineering degree, I wouldn't bother with them. The easiest route is just to play with /etc/hosts on the computer where you want to access the server from and hack it together, but this isn't optimal if you have a fleet of internal client machines.

share|improve this answer
add comment

Your question is a bit complicated in wording, so out of all the things we could advice, I need to pick one that matches what I think is your question. Basically I understand you want this:

you type your .tk domain and get directed to the site you have running on a webserver somewhere in your home.

and you currently have this

you type your .tk domain and get your router's login page

Is that rigth?

If that is so, the only thing you need to do is let your router know that traffic comming from outside for your webserver actually be redirected to the right webserver. This means you have to forward a port.

The thing is, your ROUTER has the static IP from your provider. You have a different internal IP for your webserver because you are behind that router. If you forward port 80 (for default http traffic) and possible another port for https (e.g. 443) to that internal IP, you'll be set.

Now it IS possible to do it differently, but I don't recommend this if guessing your experience

  1. set your server in the so called DMZ
  2. give your server the public 'external' IP, and route from there to your netwerk (this is weird)
  3. possibly loads of other options.
share|improve this answer
    
I type my .tk or ip address and i get my routers login page. –  Edward Meaderds Jan 2 '13 at 18:41
    
port 80 cannot be forwarded to –  Edward Meaderds Jan 2 '13 at 18:43
    
You should eleborate on that. Because it's not a general rule at all. –  Nanne Jan 2 '13 at 18:56
    
Anyway, the above answer is probably what you are looking for, the rest is finding your routers manual and fixing the "cannot forward" problem ;) –  Nanne Jan 2 '13 at 18:56
    
when i try to forward port 80 it say's remote management is causing a conflict –  Edward Meaderds Jan 2 '13 at 19:52
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.