Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(Note : This question may also concern every owner of a brand new ATI legacy card!)

I have an ATI Mobility Radeon HD 3670 on my laptop and I installed Ubuntu 12.10 a few months ago. Since then, I've been looking for some way to make the HDMI work, as the proprietary drivers do not work with the new Xorg.

Recently, I came across this post from 2007. Am I missing something? Is it possible to make the HDMI sound port work with the open source ATI driver? Is there some work around without having to install some obscure kernel or unsupported PPA?

When I execute the lspci command, I do get the lines

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV635 [Mobility Radeon HD 3670]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV635 HDMI Audio [Radeon HD 3600 Series]

which tells me that it can be used to send audio through it, but it does not appear in my Sound Settings.

** Note ** : It seems that Redhat (Bug 428964) has a patch that works with some ATI cards (including mine), why hasn't this ended up in the Ubuntu release? (Or if it did, why doesn't it work anymore?)

** Note 2 ** : Even Arch Linux has some documentation to install HDMI support with the open source ATI drivers!


Supplement

The HDMI cable is plugged in, I even rebooted the computer and tried under serval conditions, the following information are constant : The command aplay -l returns

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And finally aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav... just does nothing.

Also, this looked quite promising, but I hesitate to install PulseAudio.

Another forum discussion that looks interesting, but I lack some understanding on this one right now.

share|improve this question
    
possible duplicate of Fast video playback with no sound –  Takkat Sep 8 '13 at 7:55
add comment

1 Answer

up vote 3 down vote accepted

The following helped me to get hdmi audio back (Ubuntu 12.10; Radeon HD 4800):

It is also notable that the open source driver for ATI/AMD (called radeon), has experimental support for HDMI/DisplayPort audio, at least for some cards. It is disabled by default, but you can activate it by adding radeon.audio=1 as a kernel boot parameter \:

  1. Run gksu gedit /etc/default/grub and add the parameter to GRUB_CMDLINE_LINUX_DEFAULT. For example:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    
  2. Run sudo update-grub.

  3. Reboot.

share|improve this answer
    
I edited your answer. I already had the kernel parameter set, but just forgot to update grub! When you wrote that it worked for you, I double checked and realized my mistake. All is well now! –  Yanick Rochon Jan 5 '13 at 1:11
    
I did the same thing but still Audio still not working (kernel 3.8, ati HD4570). GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1 acpi_osi=Linux pcie_aspm=force" GRUB_CMDLINE_LINUX="persistent acpi.power_nocheck=1 radeon.agpmode=-1 radeon.pcie_gen2=1 radeon.hw_i2c=1 radeon.msi=1 radeon.modeset=1" –  Tosho May 4 '13 at 6:37
    
Here is the corresponding bug report: bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/864735 –  Takkat Sep 8 '13 at 7:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.