Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Blender 2.65a from its official site but am unable to activate the console for python. I'm unable to run in terminal since it is not installed from Ubuntu Software Center because it is five versions lagging in the repo.

However, I tried to drag the executable blender file to the terminal, Blender opened but without the console.

share|improve this question

First things first, the Blender Console on Linux is a bit different than you might expect.

Unlike on Windows, Blender's console output is placed on the command line, if run from a terminal. Also, Blender on all versions contains a built in console.
enter image description here

You can choose either a Python console or a regular console (bash), though some builds do not have this (for example the one I'm using does not).

Secondly, you can get Blender from a PPA. The builds are from svn and are built usually every week. The PPA also contains Blender 2.4x for backwards compatibility.

For 2.6x:

sudo apt-add-repository ppa:irie/blender
sudo apt-get update
sudo apt-get install blender

For 2.4:

sudo apt-get install blender 2.4
share|improve this answer
    
I think the command is most likely sudo apt-get install blender2.4 but I can't edit it. – grooveplex Jun 14 at 18:08

I return to this problem on a regular basis, and I usually find this answer when I am searching for the solution, so I figured I should add it here:

Another step that was missed, once you have installed Blender, is to go to the /usr/share/applications folder and open the blender* desktop file in a text editor, as root user (if it is updating from the PPA, it will append the svn version number to the application name).

I use the terminal to open gedit using: gksu gedit, but you could also use the key command Alt+F2, and enter the same command.

Change the preference Terminal=False to read Terminal=True, then save, and start blender, which should now open from a console/terminal window. The console will remain open, so long as blender is running (but blender will shut down if you exit the console).

This fix may only be necessary for 12.04, and does not apply to earlier versions which use the Alacarte menu system, which will allow you to add this preference with a radio button.

share|improve this answer

@ Alaa, is correct, but i could not open the blender* icon in text editor so i just fallowed these steps

  1. from terminal run gksu gedit
  2. It asks for password, enter it. it opens gedit
  3. open home folder and navigate to /usr/share/applications
  4. select the Blender* icon; drag it into into gedit window
  5. Change the preference Terminal=False to read Terminal=True
  6. save and close it
  7. run blender and the blender terminal too opens :)

@ Alaa solution in more step by step manner.

share|improve this answer

Edit your launcher

Open up your blender.desktop file in ~/.local/share/applications or /usr/share/applications/blender.desktop with a Text Editor of your choice (Sublime, Gedit etc.):

[Desktop Entry]
Name=Blender
Exec=/opt/blender-2.77a/blender %F
Icon=/opt/blender-2.77a/icons/scalable/apps/blender.svg
MimeType=application/x-blender
StartupNotify=true
Terminal=false
Type=Application

and set the 'Terminal flag' to true:

...
Terminal=true
...

This will run Blender with the Terminal window:

enter image description here

Note: To create a 'launcher' for Blender before, see this answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.