Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install the drivers for my Canon MF4150 that I successfully used under my previous 10.04 instance.
But when I run the command to install .deb packages, it gives me an error complaining that a ghostscript package is missing.
Of course trying to apt-get install that package has, it says that there's no installation candidate :

root@u1210:/Dati/DOWNLOAD/Drivers/Canon# dpkg -i *.deb
Selecting previously unselected package cndrvcups-common.
(Reading database ... 271641 files and directories currently installed.)
Unpacking cndrvcups-common (from cndrvcups-common_2.20-1_i386.deb) ...

Selecting previously unselected package cndrvcups-ufr2-uk.
Unpacking cndrvcups-ufr2-uk (from cndrvcups-ufr2-uk_2.20-1_i386.deb) ...
dpkg: dependency problems prevent configuration of cndrvcups-common: 
cndrvcups-common depends on gs-esp; however:

Package gs-esp is not installed.

dpkg: error processing cndrvcups-common (--install): 
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cndrvcups-ufr2-uk: 
cndrvcups-ufr2-uk depends on cndrvcups-common (>= 2.20); however:

  Package cndrvcups-common is not configured yet.

dpkg: error processing cndrvcups-ufr2-uk (--install):

 dependency problems - leaving unconfigured

Errors were encountered while processing:


root@u1210:/Dati/DOWNLOAD/Drivers/Canon# sudo apt-get install gs-esp

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package gs-esp is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gs-esp' has no installation candidate

How can I fix this, or use a workaround to use this drivers ??
Please give me some hints..

Thanks a lot.

share|improve this question

It looks like your debs have references to the gs-esp (Ghostscript ESP flavour) package which has been merged into GNU Ghostscript and abandoned from support.

You have at least few options (ordered by easiest coming first):

  1. Download more recent UFR II drivers - e.g. v2.50 from Canon but check whether your printer is supported by this particular version. If it doesn't work, try to find 2.40 or 2.30 and try them.

  2. Ask Cannon to repackage v2.20 if later versions (between your 2.20 and latest provided 2.50) have issues with printing.

  3. Make sure you have ghostscript installed anyway - you can try to install .deb by telling dpkg to ignore this dependency problem with key --ignore-depends=gs-esp flag. But, you have to be sure that Canon software launches gs binary not gs-esp or provide proper link from gs-esp or gr. You can get hints through googling for old package traces, and look into binary content of it.

  4. If nothing else works, you can try to build your own v2.20 .deb from source with proper reference but you have to make your own build environment, which is might be complex enough.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.