Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to play a video which requires the above mentioned plugins. I've looked at a few answers on this topic here but it hasn't resolved the issue for me.

What I've tried until now :

1) sudo apt-get install ubuntu-restricted-extras ... But this one's having some issues and skipping downloading some packages... so the whole thing doesn't get downloaded completely.

2) I've tried sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse" to add the above repositories to the ubuntu's source.list for download places but it hasn't helped.

Anyone knows what else can i try to get this working ?

share|improve this question

closed as too localized by Luis, fabricator4, hhlp, gertvdijk, Eric Carvalho Jan 2 '13 at 12:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Ubuntu 10.10 is not supported anymore, please use the latest version 12.10 or 12.04 LTS. –  Uri Herrera Jan 2 '13 at 8:56
    
Difficult to get support for an unsupported version. –  NikTh Jan 2 '13 at 9:00
    
@UriHerrera - Do you mean a fresh install of ubuntu 12.10 / 12.04 LTS or do you mean i need to get the codec packages meant for ubuntu's 12.x versions ? I'll need help in the later case as i'm not sure where/how to download them... –  user481913 Jan 2 '13 at 9:01
1  
Upgrade your OS, and install the ubuntu-restricted-extras package. –  Uri Herrera Jan 2 '13 at 9:01
    
@UriHerrera Can i just run the update to upgrade the OS or does this need a fresh install ? –  user481913 Jan 2 '13 at 9:05

1 Answer 1

You will have to download CODECS.

To install the proprietary CODECs type the following in a terrminal window.

32 bit OS

sudo apt-get -y install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

64 bit OS

sudo apt-get -y install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

Once you have installed these CODECs you will be able to play nearly any audio/video format.

And yeah i also recommend you to Upgrade to 12.04LTS .

share|improve this answer
    
All of them contained in the ubuntu-restricted-extras package..., did you tested this on Maverick? did this worked for you on Maverick?. –  Uri Herrera Jan 2 '13 at 9:45
    
Yeah it did work on Maverick.. –  Mukund Jan 2 '13 at 9:49
    
@Mukund - I tried the command for trhe 32 bit version, however i encountered the following errors. 1)There are problems and -y was used without --force-yes. So i replaced -y with --force-yes and tried again...This time there's problem downloading certain packages i.e issue no. 2 2)Failed to fetch archive.ubuntu.com/ubuntu/pool/multiverse/g/… 404 Not Found [IP: xxx.xxx.xxx.xxx 80] Try runnning apt-get update or --fix-missing. So what next ? –  user481913 Jan 2 '13 at 11:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.