Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I start any Qt app, I get this message in the terminal, and the Qt app doesn't use the same theme as my Gtk apps:

QGtkStyle was unable to detect the current GTK+ theme.

How do I make QGtkStyle detect my current GTK+ theme?

It seems that LXDE is using a settings daemon, and there is no gtkrc-2.0 file in my home folder.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Try with:

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

Also make sure you defined a theme in yout gtkrc-2.0 like this:

gtk-theme-name="myTheme"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.