Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(((Anticipating the "Why are you using Compiz with XFCE?!?!?!?!" comments)))

I am using the following setup:

XFCE panel on top and bottom of screen Compiz as a window manager.

I have an application that I enjoy running in full screen, but when I run it, it is under the panel. The icons of the panel are in the application and they get in the way of the application itself. Is there a way, either with Compiz or XFCE itself, to have the panel sit below this application, and only this application?

share|improve this question
    
Do you have the "intellihide" on? –  CoffeeRain Jan 2 '13 at 16:13
    
Sadly, XFCE doesn't have an intellihide option :( –  Ryan McClure Jan 3 '13 at 0:46
    
Mine is just hidden until the bottom of the screen is moused over. Did you not want that, or is it not working? –  CoffeeRain Jan 3 '13 at 15:11
    

1 Answer 1

Actually, you can right click on the window's title bar and choose 'Always On Top', that will bring it above any panel, providing that panel has the following setting checked in Panel Properties: Do Not Reserve Space on Borders' which can be found by:

Right click the problem panel, choose Panel>Panel Preferences> 'Display' tab, under General.

It seems to me that all the functionality to have an Intellihide option is actually there already in XFCE Panel, it just needs to tell the display manager that it is to be ordered to the bottom, so that all other windows are drawn over the top. Given that my answer above creates this very scenario, only manually, rather than automatically.

Having said that, I've never programmed anything in my life ^^

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.