Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Getting permission denied when trying to download or move_storage of a torrent to a mounted drive (saw the error with deluded).

The drive is an internal HDD mounted with this command at /etc/fstab.

/media/username/584C1E8B4C1E63D2    ntfs-3g defaults,locale=en_US.utf8  0   0

What's the solution to this?

OS: Ubuntu 12.10, 64bit

share|improve this question
    
Can you create any files on that drive as your "normal" user? –  Sergey Jan 2 '13 at 3:32
    
@Sergey: Nope..Should I change the ownership of this driver? With chown maybe? But why I don't have rights to create files? –  Chris Jan 2 '13 at 3:35

1 Answer 1

up vote 1 down vote accepted

NTFS is not a "proper" Linux file system - it does not support traditional Unix permissions. Because of that, you need to specify an option when mounting the partition which tells the ntfs driver which permissions to report for all files and directories. See this question for more details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.