Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Lubuntu 12.10. Here are the specifications of my laptop:

  • Lenovo ThinkPad T60 (2006)
  • 1.66 GHz Intel Centrino Duo processor
  • 2 GB DDR2-667 RAM
  • 120 GB Hard Drive (Windows 8 Pro, and Lubuntu 12.10)
  • Mobile Intel 945 Express Video (256 MB)
  • Intel PRO/Wireless 3945ABG

If I log into Lubuntu, it gives me a notification that I am not connected to wireless networking (typical). I go to the networking menu, and click on my wireless network. It then asks for the password to log into the network. I type it in, and tell it to log in, but then it says that the password is incorrect. It then asks me to type it in again, but that still fails. I am sure I am typing in the correct password for that network.

If I close the box, after I try to connect, it says that I have insufficient privileges to modify the wireless settings. I don't understand this, as I am the administrator of the system.

This is really bugging me, and I hope that there is a fix to this. Please help!

share|improve this question

Are you sure it is asking you for the password for the wireless network, and not your user password in order to access the keyring that contains the key for the network? The first time you enter the password, it will normally save this paassword to the keyring, then it won't need to keep asking you every time. I believe it uses your login password as the keyring password, but if these are different, then it will prompt you for the keyring password. The default behavior always works well for me, but in the past, I've had problems with this when I didn't understand the behavior, but tried to do something non-standard anyway.

The next thing you should understand as soon as you can is that there is no such thing as "administrator" of the system, per se. There is root authority, but you do not normally use this, ever. Instead, Ubuntu has a way to temporarily give you elevated privileges, using sudo, or gksu. Using your normal login, you should never have privileges to change the system. But there is an easy way to do it, by using the built-in methods I mentioned. This is not something to be worked around, it is there for your protection. Yes, you need it, unless your system is a throwaway system that you don't mind fixing or reinstalling regularly.

share|improve this answer

check for authentication protocol also. some time mismatch in authentication protocol can give you feel as the password is wrong and not able to connect. check with device or your service provider for authentication protocol being used and use the same.

share|improve this answer

I have had this same issue myself. I can not answer why this happens exactly but I do have some ideas. To resolve this issue for me I did the following. Click on the network manager applet in the panel, go to edit connections In the network connections dialog click the wireless tab delete the existing entry for your wireless connection,provide your administrator password if prompted. Now reboot your computer so network manager will not have an existing wireless configuration to attempt to load. After rebooting try to reconnect to your wireless network as though this is the first time this computer has connected to your network.

Some added helpful hints: It seems that sometime after 12.04 LTS. or 12.10 not sure which, network manager installs or upgrades with IPv6 set to Automatic. in my case with a moderate size home network with my router managing my global gateway (Internet connection) IPv6 protocols are not necessary and the automatic setting in the IPv6 settings tab of the Network Connections dialog seems to cause some buggy behavior with dhcp connections and my Ubuntu systems so I have set this to ignore.

A word of WARNING! about setting IPv6 to ignore. In some Countries or areas Internet Service Providers or Corporations may be using the Ipv6 protocol and this setting may not be right for every one but works well for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.