Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.04 and have a HP-Laserjet-3005P network printer. Occasionally (perhaps related to rebooting) the printer, which is setup as the default printer, becomes disabled. After realizing that I'm not getting anything printed, I must then open printing preferences and click on "enabled". Then it prints happily until the next time that it becomes disabled...

Any ideas why this is happening and/or how I could fix it?

I know I'm giving very little information, I can't think of anything else to give...if there's something I should be providing, please let me know.

share|improve this question

2 Answers 2

Try setting the printer as enabled from the printer manager when the printer is disconnected. If it still doesn't work, try to boot your system after you have switched on your printer.

share|improve this answer
    
"disconnected" from what? it is a network printer, so I am not sure I should go and disconnect the departmental printer... –  Yossi Farjoun Feb 3 '11 at 9:22
    
I thought that you were using an USB connection. Maybe you should try to disable networking in your PC, then set your printer to enabled and finally re-enable networking. Did you try my second suggestion yet? –  papukaija Feb 3 '11 at 20:25

I have the same problem but I found a workaround with adding the command

cupsenable [PRINTERNAME]

to /etc/crontab to be executed every 5 minutes. I had to get it to work because this problem occurs even in 11.04 and 11.10 and we're using Ubuntu in a training classroom. The printer is never switched off so that cannot be the source of the problem. [PRINTERNAME] has to be replaced with the name of the printer in the settings. For example, if the printer is labeled "HP-Laserjet-3005P" you can type

sudo su
*type password*
echo -e "#Fix CUPS disabling\n*/5 *\t* * *\troot\tcupsenable HP-Laserjet-3005P" >> /etc/crontab

to make sure printing will start at least after 5 minutes (if you want shorter times just replace the 5 with a 2 for 2 minutes or 1 for 1 minute).

share|improve this answer
    
hmmm. I am not an admin on that machine.... –  Yossi Farjoun Jan 15 '12 at 13:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.