Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu 10.10 on a work PC (32bit) to be dual-booting with Win XP.

My partition layout is:

  • /dev/sda
  • -- sda1 - 250gb ntfs WinXP
  • /dev/sdb
  • -- sdb1 - 160gb ntfs
  • /dev/sdc
  • -- sdc1 - 161gb ext4 (this is where ubuntu is
  • -- sdc5 - 4 gb swap

I tried following the suggestion of the answer to this question, but get the following in the terminal as a response:

root@ubuntu:/# sudo grub-install /dev/sda
sudo: unable to resolve host ubuntu
/usr/lib/grub/grub-mkconfig_lib: 38: cannot create /dev/null: Permission denied
/usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).

How should I proceed? I'd really like to move away from Windows being my only development environment.

EDIT: it would seem that this problem is due to a non-stardard bios and hardware restrictions on my work computer. I managed to install ubuntu at home with no issues. Don't know how to close a question as too localised / no real question? Many thanks to Mr Rooney for trying to help.

share|improve this question
add comment

1 Answer 1

You should install GRUB into the Master Boot Record of /dev/sdc and configure your bios to boot from that drive first - GRUB will detect your Windows XP installation and add it as a boot option.

Have a look at this site it has a good description with screen shots to guide you through the install.

share|improve this answer
    
Hi there, thank you for your answer. For some reason I had it in my head that the bootloader needed to be on the first partition of the first drive. I'll try this out over lunch, hopefully it does the trick. –  TZHX Jan 27 '11 at 10:59
    
Let me know how you go - have a good read through the section on the webpage that talks about installing GRUB onto the MBR of your hard disc. –  Mark Rooney Jan 27 '11 at 11:12
    
Mark: this didn't work for me. I got the same error trying to install onto sdc, also tried installing on sdb - same thing happened. When I look in the BIOS though, there doesn't seem to be any way to set the second/third hard disks as boot devices? The only option is to turn them on or off. –  TZHX Jan 27 '11 at 14:44
    
Follow the complete install as shown on the website and install GRUB into the MBR of dev/sdc. Once you have done this you need to configure the bios of your PC to boot from dev/sdc first - the easiest way to do this is go into advanced settings for drive management and highlight the drive you know you installed Ubuntu on and set it as the first boot device, typically you will need to 'shift' it up to the top entry on the boot list. –  Mark Rooney Jan 29 '11 at 0:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.