Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I install BCM43142 wireless drivers for Dell Vostro 3460/3560?
Dell Inspiron 5720 Wifi (Broadcom BCM43142, Ubuntu 12.10)

I already asked about this twice before and didn't get any help, so here goes take three.

I bought this machine both because it was a great deal on a switchable-graphics machine, and because it had Ubuntu preinstalled. So here goes the story in detail.

When I first unboxed and powered on the machine, wireless worked out of the box in the preinstalled Ubuntu 10.10. Then I started upgrading and updating stuff, with the intention of taking the long way around up to 12.04 LTS or 12.10 - whichever worked.

In the process, I did something stupid: I installed the Broadcom proprietary wireless driver suggested by the Additional Drivers module, and wireless stopped working altogether!

I struggled with finding a fix for a few days, and then out of sheer and utter frustration, I went out and bought me a copy of Windows 7 Professional 64-bit and ran that. Natch, everything worked flawlessly, including wireless.

Last week, I then decided to try again. So I set aside a Windows disk image and tried a fresh installation 10.10 and then 11.04, 11.10, 12.04 and 12.10, but had no success getting wireless to work on any of them. So I put the Windows disk image back in and ran the machine with no issue this week.

Then last night I decided to try yet again, so I tried out another fresh installation of 10.10 and then 12.04. I got as far as resolving the "Fatal" issue with the Windows Drivers module, but even installing the Windows driver doesn't resolve the wireless issue - I still get the message "Hardware present: no."

But when I run the lspci command in terminal, is does list out the Broadcom network device as:

09:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)

I'm sorry for the lengthy post and repeated question, but I really wanted (and still want) to like Linux and Ubuntu and wean myself off of Microsoft, but this sort of trouble doesn't help. So, I need your help, ladies and gents.

Thanks in advance!

share|improve this question

marked as duplicate by Web-E, Jorge Castro, nitstorm, fossfreedom Jan 1 '13 at 20:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please check here: askubuntu.com/questions/215890/… –  chili555 Jan 1 '13 at 15:11
    
Awesome! I followed the instructions in chili555's link and we're in business! Thanks a whole lot! Where were you before??! –  Shady Jan 1 '13 at 16:02
    
Glad it's working! Welcome to Ubuntu. –  chili555 Jan 1 '13 at 16:10
add comment

Browse other questions tagged or ask your own question.