Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was updated my Ubuntu 12.04.1 LTS kernel to version 3.5.0-18-generic so I need to recompile my broadcom-sta to work with the new kernel

I was run

ubuntu@ubuntu:~$ sudo dpkg-reconfigure broadcom-sta-dkms

------------------------------
Deleting module version: 5.100.82.112
completely from the DKMS tree.
------------------------------
Done.
Loading new broadcom-sta-5.100.82.112 DKMS files...
Building only for 3.5.0-18-generic
Building initial module for 3.5.0-18-generic
ERROR (dkms apport): kernel package linux-headers-3.5.0-18-generic is not supported
Error! Bad return status for module build on kernel: 3.5.0-18-generic (i686)
Consult /var/lib/dkms/broadcom-sta/5.100.82.112/build/make.log for more information.

And here is the log file

ubuntu@ubuntu:~$ cat /var/lib/dkms/broadcom-sta/5.100.82.112/build/make.log
DKMS make.log for broadcom-sta-5.100.82.112 for kernel 3.5.0-18-generic (i686)
Tue Jan  1 19:30:03 ICT 2013
make: Entering directory `/usr/src/linux-headers-3.5.0-18-generic'
Wireless Extension is the only possible API for this kernel version
Using Wireless Extension API
Kernel architecture is X86_32
  LD      /var/lib/dkms/broadcom-sta/5.100.82.112/build/built-in.o
  CC [M]  /var/lib/dkms/broadcom-sta/5.100.82.112/build/src/shared/linux_osl.o
/bin/sh: 1: /usr/src/linux-headers-3.5.0-18-generic/scripts/recordmcount: Permission denied
make[1]: *** [/var/lib/dkms/broadcom-sta/5.100.82.112/build/src/shared/linux_osl.o] Error 126
make: *** [_module_/var/lib/dkms/broadcom-sta/5.100.82.112/build] Error 2
make: Leaving directory `/usr/src/linux-headers-3.5.0-18-generic'

How can I fix this. I really need it

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.