Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i do upgrade or install, im getting this error.

srikanth@btp8sa42:~/projects/raff$ sudo apt-get upgrade
[sudo] password for srikanth: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcurl3-gnutls : Depends: libc6 (>= 2.15) but 2.13-20ubuntu5.3 is installed
               Depends: libgnutls26 (>= 2.12.6.1-0) but 2.10.5-1ubuntu3.2 is installed
               Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.9.1+dfsg-1ubuntu2.3 is installed
 libp11-kit0 : Depends: libc6 (>= 2.14) but 2.13-20ubuntu5.3 is installed
E: Unmet dependencies. Try using -f.

When i do "apt-get -f install"

srikanth@btp8sa42:~/projects/raff$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libcurl3-gnutls : Depends: libc6 (>= 2.15) but 2.13-20ubuntu5.3 is installed
               Depends: libgnutls26 (>= 2.12.6.1-0) but 2.10.5-1ubuntu3.2 is installed
               Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.9.1+dfsg-1ubuntu2.3 is installed
 libp11-kit0 : Depends: libc6 (>= 2.14) but 2.13-20ubuntu5.3 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

How can i fix this?

share|improve this question
    
This question may help you askubuntu.com/questions/140246/… –  Chris Carter Jan 1 '13 at 12:01
    
@ChrisCarter No, not a duplicate. That question seems to be about a different error. In this case he seems to have put some packages on hold. Srikanth should provide a list of all held packages (can someone give the right ˋdpkgˋ command for that?). –  gertvdijk Jan 1 '13 at 15:20
    
List of all held packages? –  SrikanthJeeva Jan 2 '13 at 6:30

1 Answer 1

up vote 1 down vote accepted

This has solved the problem.

Doing a

apt-get install libp11-kit0/oneiric libcurl3-gnutls/oneiric 

fixed this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.