Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I really have tried a number of the solutions posted on similar questions, no matter what approach I attempt, I can only ever install the following packages:

ii  libvlc5                                    2.0.3+git20121229+r489-0~r41~precise1   multimedia player and streamer library
ii  libvlccore5                                2.0.3+git20121229+r489-0~r41~precise1   base library for VLC and its modules
ii  vlc-data                                   2.0.3+git20121229+r489-0~r41~precise1    Common data for VLC
ii  vlc-nox                                    2.0.3+git20121229+r489-0~r41~precise1   multimedia player and streamer (without X support)

I up until yesterday had the vlc player installed, but a failed attempt at installing skype removed a ton of packages from my system, vlc being one of them.

Here is a link to the captured output of whenever I run sudo apt-get install vlc:

https://gist.github.com/d43204060bf3fe0532c9

share|improve this question
    
It seems to me that the problem is with libqtcore4, it has been updated to version 4.1, but a number of libqt libraries that depend on libqtcore4 are still depending on version 4.0. This most likely explains why vlc and virtualbox where removed from my system when I was hap-hazardly trying to install skype. I suppose a downgrade to libqtcore4 could work, is there any other solutions if I my assumption is correct? –  Dan Schmidt Jan 1 '13 at 5:13

2 Answers 2

up vote 1 down vote accepted

The problem was that libqtcore4 had been upgraded while a large number of libqt packages still depended on the previous version. The solution was to downgrade libqtcore4 and I was able to install VLC successfully after doing this. Here is a great post on downgrading packages in Ubuntu if you are facing a similar problem:

http://ubuntuforums.org/showthread.php?t=321156

share|improve this answer

VLC is in Ubuntu Software Centre it self. Open your Software Centre and type VLC in the search field. you will find it to install.

share|improve this answer
    
This has already been attempted by me, it gives me a different unmet dependencies error: gist.github.com/547951dbeea6bba89a69 –  Dan Schmidt Jan 1 '13 at 3:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.