Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to install Ubuntu 12.04 LTS in OEM mode on a few desktops via usb drive.

These instructions work fine to install in OEM mode on a VM using the .iso from Ubuntu site : How do I pre-install Ubuntu for someone (OEM install)?

But as soon as I add that .iso to my USB the only option that shows up when I press f4 for the advance installation modes is "normal".

I'm using rufus to add the image to my flash drive and encountering this issue. I've also tried using unetbootin and I can't seem to get the advance installation options to show up by pressing f4.

Ideally I'd like to just make a permanent change to the boot options so the image boots in OEM mode since I will use this periodically for that purpose.

If that's not an option I'd be fine with suggestions for other programs that I can use to add the image to the usb and test to see if it will still have an OEM option.

share|improve this question
add comment

2 Answers

This is an example a bootable USB key (Backtrack/Ubuntu based) made using unetbootin

tree -L3

.
├── autorun.inf
├── boot
│   └── grub
│       ├── efi.img
│       ├── font.pf2
│       ├── grub.cfg
│       ├── loopback.cfg
│       └── x86_64-efi
├── casper
│   ├── filesystem.manifest
│   ├── filesystem.manifest-desktop
│   ├── filesystem.manifest-remove
│   ├── filesystem.size
│   ├── filesystem.squashfs
│   ├── initrdf.gz
│   ├── initrd.gz
│   ├── initrd.lz
│   ├── initrds.gz
│   ├── README.diskdefines
│   ├── vmlinuz
│   └── vmlinuz.efi
├── EFI
│   └── BOOT
│       ├── BOOTx64.EFI
│       └── grubx64.efi
├── install
│   └── mt86plus
├── isolinux
│   ├── adtxt.cfg
│   ├── chain.c32
│   ├── dtmenu.cfg
│   ├── exithelp.cfg
│   ├── f10.txt
│   ├── f1.txt
│   ├── f2.txt
│   ├── f3.txt
│   ├── f4.txt
│   ├── f5.txt
│   ├── f6.txt
│   ├── f7.txt
│   ├── f8.txt
│   ├── f9.txt
│   ├── gfxboot.c32
│   ├── gfxboot.cfg
│   ├── isolinux.bin
│   ├── isolinux.cfg
│   ├── memtest
│   ├── menu.cfg
│   ├── po4a.cfg
│   ├── prompt.cfg
│   ├── rqtxt.cfg
│   ├── splash.png
│   ├── stdmenu.cfg
│   ├── txt.cfg
│   └── vesamenu.c32
├── ldlinux.sys
├── md5sum.txt
├── menu.c32
├── preseed
│   ├── cli.seed
│   ├── custom.seed
│   ├── ltsp.seed
│   └── ubuntu.seed
├── syslinux.cfg
├── ubnfilel.txt
├── ubninit
├── ubnkern
├── ubnpathl.txt
├── ubuntu
└── wubi.exe

There 3 boot configuration folders:

  • /boot/grub/grub.cfg : Ubuntu original live cd boot configuration (Not used)
  • /isolinux/isolinux.cfg : Backtrack live cd boot configuration (Was used by ISO)
  • /syslinux.cfg : Unetbootin usb boot configuration (Used by USB, has some entries copied from ISO config by unetbootin)

All this configuration files have all most same syntax. We can just copy the entry we want to syslinux.cfg

As in your case it should the OEM entry:

label oem
menu label OEM install (for manufacturers)
linux /casper/vmlinuz
append initrd=/casper/initrd.gz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true --

You can learn from isolinux how make advanced menu. Make a look on all text files there.

share|improve this answer
add comment

I've encountered this problem several times.

To remedy the issue I used "Universal USB Installer" to create bootable flash.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.