Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having an issue that seems to be pretty common both on here, and the Ubuntu Forums. Sadly, I couldn't find any solutions that corresponded to my particular laptop model.

The issue is simply: the wireless connection will randomly drop. When this happens, the connection to the network is still active according to the network manager. It's quite obvious that the connection has dropped, though; internet access no longer works. When I disconnect and reconnect, it works for a little while before dropping again.

I've tried the common sense solutions: checking Additional Drivers (nothing there), checking to make sure there is nothing wrong with the router, etc. I also tried installing linux-backports-modules-cw-* from the repository (a common solution floating around on the forums). This activated my ethernet port (another issue I was having), but it didn't make a difference in regard to the wireless connection dropping.

The operating system I'm using is Ubuntu 12.10 64 bit, and the laptop is a Toshiba Satellite C855-S5343.

    $ sudo lshw -C network

    *-network               
   description: Ethernet interface
   product: AR8162 Fast Ethernet
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: eth0
   version: 10
   serial: 00:8c:fa:26:2d:bd
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=alx firmware=alx latency=0 link=no multicast=yes port=twisted pair
   resources: irq:43 memory:c8500000-c853ffff ioport:3000(size=128)
    *-network
   description: Wireless interface
   product: RTL8188CE 802.11b/g/n WiFi Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 01
   serial: 20:16:d8:1d:97:2a
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192ce driverversion=3.5.0-21-generic firmware=N/A ip=192.168.1.4 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 ioport:2000(size=256) memory:c8400000-c8403fff

    $ dmesg

    [   17.101237] wlan0: authenticate with 00:1f:33:dc:55:e5
    [   17.120299] wlan0: send auth to 00:1f:33:dc:55:e5 (try 1/3)
    [   17.127313] wlan0: authenticated
    [   17.127463] rtl8192ce 0000:02:00.0: wlan0: disabling HT due to WEP/TKIP use
    [   17.142316] wlan0: associate with 00:1f:33:dc:55:e5 (try 1/3)
    [   17.144423] wlan0: RX AssocResp from 00:1f:33:dc:55:e5 (capab=0x411 status=0 aid=5)
    [   17.144541] wlan0: associated
    [   17.146380] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.