Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

happy new year!

Not so for my PC :o) While installing the IA32-libs my PC ran into a broken package problem. ( The system is ubuntu 12.10 - 64 bit and I want to compile 32bit targets.)

The console output is vague about this but I did get more information out of the GUI update-manager:this is the output:

"De afhankelijkheden van de volgende pakketten konden niet geïnstalleerd worden:

libgl1-mesa-dri:i386: Depends: libgcc1 (>= 1:4.1.1) maar 1:4.7.2-2ubuntu1 is geïnstalleerd"

That's Dutch for: libgl1-mesa depends on libgcc1 1.4.1.1 but 1.4.7.2 is already installed on my system.

The real problem is the inability for apt-get to overcome this because I can't perform any updates, not by the console nor the GUI update manager. So My PC is basically stuck.

I tried ; apt-get install -f, remove, autoremove, update, upgrade. and so on.

Has someone an idea how to solve this?

many thanks rm

share|improve this question

1 Answer 1

I just found an answer to my own question:

http://www.webupd8.org/2011/02/fix-dpkg-error-trying-to-overwrite-x.html

sudo dpkg -i --force-overwrite /var/cache/apt/archives/yourbrokenpackage.deb

then:

sudo apt-get install -f

That did the trick for me.but I really don't know what really happened to the broken files. The --force-help file says :

"Overwrite Overwrite a file from one package with another"

So, I don't know but at least my update manager is back ;o)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.