Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to view any wireless networks (accessible through other devices). In the nm-applet I can see that the 'Enable wireless' is selected. Could anyone please let me know what the problem is ?

I am providing outputs for some commands which were suggested in related questions Please let me know if any other information is necessary.

lspci -nn |grep 0280

04:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)

lshw -c network

  *-network               
   description: Wireless interface
   product: AR928X Wireless Network Adapter (PCI-Express)
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: wlan0
   version: 01
   serial: f0:7b:cb:13:36:20
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=3.5.0-19-generic firmware=N/A latency=0 multicast=yes wireless=IEEE 802.11abgn
   resources: irq:16 memory:fbef0000-fbefffff
  *-network
   description: Ethernet interface
   product: NetLink BCM57780 Gigabit Ethernet PCIe
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:05:00.0
   logical name: eth0
   version: 01
   serial: a4:ba:db:ec:bf:0e
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 duplex=full firmware=sb v2.05 ip=192.168.51.250 latency=0 multicast=yes port=MII speed=1Gbit/s
   resources: irq:48 memory:fbff0000-fbffffff

rfkill list

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

sudo iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

clearwlan0     IEEE 802.11abgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=21 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off

dmesg|grep ath9

[   20.169143] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
[   20.169414] Registered led device: ath9k-phy0
share|improve this question
add comment

1 Answer 1

Try adding a network manually by clicking on the network icon, selecting edit connections, wireless, then add. Enter the network SSID, then follow these instructions to refresh the connections. Connecting and refreshing a wireless network without restart. You may also have to install drivers even though your computer sees the device.

share|improve this answer
    
I tried manual addition of networks, but it wasn't fruitful. I also tried installing the drivers through the package linux-backports-modules-cw-3.6-3.5.0-21-generic (compat-wireless Linux modules for version 3.5.0 on x86/x86_64). But there was a breakdown of the system on restart after this installation (one of the displays, keyboard, mouse did not work). So I had to reinstall the system, after failing to restore the system, using a live usb. Please let me know if there is any other way to install the drivers. –  Vijay Dec 31 '12 at 22:00
    
This was the method that worked for me, but I'm sure that there are more experienced users who can help, sorry. –  Arathorn867 Jan 1 '13 at 1:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.