Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problem with mounting.. I bought iOmega Storage box ix200. I shared a folder from iOmega box for 10 users.

I mounted this shared drive in all 10 Virtual machines by editing /etc/fstab file. After rebooting the drive got mounted. But when a user accessing it and tries to create a new file it shows lock symbol on it.

But if i try to access this drive from Menu - Location and, from there put File server IP and do then i am able to create a file without lock symbol. It's opening read-only for all the users.

This is happening for all the users except 1 user. If i assign that user then its working fine. Can someone guide me what may be the issue.


Hi Thanks for your response. Please find below information

    root@JHSP-Christopher:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=d82e0cc6-4bff-4dba-89af-1d5965057568 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=041df524-1e47-4ba2-9046-1f8aee0870ad none            swap    sw              0       0

//192.168.1.150/worksdaily /media/JHSP-FS smbfs username=christopher,password=chh156 rw 0 0
//192.168.1.150/christopher /media/Christopher smbfs username=christopher,password=chh156 rw 0 0
root@JHSP-Christopher:~# mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
//192.168.1.150/christopher on /media/Christopher type cifs (rw)
//192.168.1.150/worksdaily on /media/JHSP-FS type cifs (rw)
gvfs-fuse-daemon on /home/jhsp/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=jhsp)
gvfs-fuse-daemon on /home/christopher/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=christopher)
root@JHSP-Christopher:~# ls -ld $(mount | cut -d ' ' -f 3)
drwxr-xr-x  23 root        root        4096 Dec 19 19:18 /
drwxr-xr-x  14 root        root        4080 Jan  6 19:10 /dev
drwxr-xr-x   2 root        root           0 Jan  6 19:10 /dev/pts
drwx------   2 christopher christopher 4096 Dec 20 00:13 /home/christopher/.gvfs
drwx------   2 jhsp        jhsp        4096 Dec 18 15:02 /home/jhsp/.gvfs
drwxrwxrwx   2          99 users          0 Jan  5 14:40 /media/Christopher
drwxrwxrwx   6          99 users          0 Jan  7 17:51 /media/JHSP-FS
dr-xr-xr-x 232 root        root           0 Jan  6 19:10 /proc
drwxr-xr-x  23 root        root         980 Jan 11 19:50 /run
drwxrwxrwt   3 root        root          60 Jan 11 17:35 /run/lock
drwxrwxrwt   2 root        root         320 Jan 11 19:36 /run/shm
drwxr-xr-x  13 root        root           0 Jan  6 19:10 /sys
drwxr-xr-x   4 root        root           0 Jan  6 19:10 /sys/fs/fuse/connections
drwx------  14 root        root           0 Jan  6 19:10 /sys/kernel/debug
drwxr-xr-x   3 root        root           0 Jan  6 19:10 /sys/kernel/security
share|improve this question
1  
The lines that you use to mount your shares would be nice... –  Bruno Pereira Dec 31 '12 at 16:16
    
Please add to your question the output of the following commands: cat /etc/fstab, mount and ls -ld $(mount | cut -d ' ' -f 3) –  Flimm Dec 31 '12 at 16:32

1 Answer 1

May be there is a problem in fstab entries. Check out 4th column for mount options and ensure that it is not in ro. That means read-only. If it is so, then change it to rw- read write.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.