Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Compaq Presario C700 which has a GRUB multi-boot for Ubuntu 12.10 (32 bit), Ubuntu 10.10 and Windows Vista. This machine is always run by mains electricity rather than by battery as I have hooked it up to my 40" TV. It works like a dream in every respect - except one... If I want to watch a video longer than 10 minutes the power-saving blank screen associated with an inactive keyboard/mouse kicks in; a tap of a key or movement of the mouse restores the display instantly. This is irritating and happens for both 10.10 and 12.10. I have tried the following remedies:

  • Checked BIOS for advanced setting that might override Ubuntu commands (no such settings exist)
  • Changed system Power settings in 12.10 to 'Don't suspend' (battery or plugged in) for inactive behavior and 'Do nothing' when lid is closed for battery and plugged in. "When power is critically low" has been left with the default blank (although this is not really applicable as the unit is always plugged in).
  • Changed system Brightness and Lock settings in 12.10 to 'Turn screen off when inactive for:' to Never. Lock is set to 'Off' and 'Turns screen off' option is greyed out. Brightness is set to maximum and 'Dim screen to save power' is unchecked.
  • I have checked out the Displays, Keyboard and mouse settings but there is nothing of relevance there.
  • I have seen a similar question on Ask Ubuntu but there were no satisfactory permanent solutions for Ubuntu 12.10 “Turn screen off when inactive for: Never” still turns off as
  • sudo xset s off did not work
  • sudo xset s 0 0 did work within the session (screensaver timeout = 0; cycle =0 ) but on rebooting from cold xset q showed a reverted screensaver timeout = 600; cycle = 600 - so it is not an acceptable solution. (Yes - I do have administrator rights!)

One annoying facet of this problem is that the screen goes blank after 10 minutes of inactivity and it takes 10 (very long) minutes to find out if a solution has worked so any trial and error method of solving this has a significant time penalty for me.

Has anyone experienced and successfully overcome this problem?

share|improve this question
    
I have found this relevant [bug report] (bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1072531) I have also tried editing dconf power settings as per [this item] (askubuntu.com/questions/207131/screensaver-blanking-problem) with no success. –  Morris Dec 31 '12 at 17:09
    
... there's also talk of using software called 'Caffeine' but this is not available from the Software Center - which makes me a little cautious. If this is a bug being addressed for the next release (how can I find out?), it's probably not with the trouble. If it's not on the celestial fix list, has anyone a better suggestion than a lifelong caffeine addiction? Here's a typical caffeine link askubuntu.com/questions/129541/… –  Morris Dec 31 '12 at 19:22

1 Answer 1

This is how I do it for v12.10

Go to the dconf Editor > settings daemon > plugins > power (schema: org.gnome.settings-daemon.plugins.power)

Make sure the boxes for "idle-dim-ac" and "idle-dim-battery" are both unchecked. That will set both booleans to false. If that doesn't work, there is a work-around in one of the launchpad bug reports: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1072531/comments/19

If you want to turn all power savings features off completely all at once, uncheck the box at "active" in that power section. IMHO, not a good idea, but you said you were wondering how to do that also.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.