Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT 3: See bottom, for TL;DR-ish version.

I want to install wine1.5, from the ppa:ubuntu-wine/ppa repository. Fair enough right?

(I'm running 12.04 x64 and a custom kernel.)

I added their repository. Works fine.

I apt-get updated. Ran fine. (I did this with my repository commented out. sources.list is basically the default one minus extras, partner and deb-src entries)

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get install wine1.5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. --SNIP--

The following packages have unmet dependencies:
 wine1.5 : Depends: wine1.5-i386 (= 1.5.20-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

Okay then...

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get install wine1.5-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. --SNIP--
The following packages have unmet dependencies:
 wine1.5-i386:i386 : Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                          libgl1:i386
                 Depends: libglu1-mesa:i386 but it is not going to be installed or
                          libglu1:i386
E: Unable to correct problems, you have held broken packages.

I follow that error message around a bit.

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get install libgl1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgl1:i386 is a virtual package provided by:
  libgl1-mesa-swx11:i386 8.0.4-0ubuntu0.2
  libgl1-mesa-glx:i386 8.0.4-0ubuntu0.2
You should explicitly select one to install.

E: Package 'libgl1:i386' has no installation candidate

Kept going...

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get install libgl1-mesa-glx:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. --SNIP--

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libdrm2:i386 (>= 2.3.1) but it is not going to be installed
                    Recommends: libgl1-mesa-dri:i386 (>= 7.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This is getting a little old...

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get install libdrm2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. --SNIP--

The following packages have unmet dependencies:
 openssh-client : Depends: adduser (>= 3.10) but it is not going to be installed
              Depends: passwd
 openssh-server : Depends: upstart-job
              Depends: adduser (>= 3.9) but it is not going to be installed
              Depends: procps
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get install  openssh-client openssh-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
openssh-client is already the newest version.
openssh-server is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I do have a local repository where I copy the archives in my /var/cache/apt/archives folder and generate an index using them. I use this to update this machine and the three other machines in the house, rather than downloading the packages multiple times. This archive is not signed, and results in "Do you want to install these unsigned packages?"

Also, a fairly large amount of packages are listed in synaptic's "Installed (Manual)" list. Could this be related to the issue?

EDIT: I also tried some fairly common "fix apt-get" techniques:

root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@e330:/home/nroach44/local/build/linux/src/3.5.7/linux-3.5.7# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

EDIT 2: /var/log/dist-upgrade/ was empty. /var/log/apt/ contained no relevant information. Also, dpkg --get-selections | grep hold doesn't return anything.

EDIT 3: After two re-installs, it appears that kernel-package conflicts with wine. On a fresh installation:

root@e330:~# apt-get install wine kernel-package
--Standard apt-get loading stuff--
Some packages could not be installed blah blah

The following have unmet dependencies:
 kernel-package : depends: po-debconf but it is not going to be installed
                    ""   : gettext    """"""

The thing that annoys me is that I have these two installed on my desktop, and everything works fine.

share|improve this question
    
+1 because there are so few questions with all the information needed. I don't think you missed a thing. –  Luis Alvarado Dec 31 '12 at 4:06
    
@LuisAlvarado I've been on both sides before, so I know how being thorough helps. Thanks! –  NRoach44 Dec 31 '12 at 4:27
add comment

2 Answers 2

Create New source list using this website. Select your version and choose sources as per your requirement.Tick out Wine in extra repository list. Click on Generate list, You will get generated source list.

Now edit your source list using executing following command on Terminal

sudo nano /etc/apt/sources.list

Delete all lines and Copy generated list, save file by pressing Ctrl+X, choosing Yes. Update your package list using

sudo apt-get update

Now try to installl Wine

sudo apt-get install wine

Fixed same problem before an hour on my system.

share|improve this answer
    
Nope, didn't work. Same issue. –  NRoach44 Dec 31 '12 at 13:11
add comment

Do you have installed ia32-libs or ia32-libs-multiarch on your 64-bit system?
I recently had vey weired issues with dependencies and a broken trackpad on my E330 after installing ia32-libs.

After messing around for days and a few clean installs i found out, that i had to install ia32-libs as first package of all, after a clean install.

Previously i installed about 30 packages and ia32-libs was one of the last ones - this caused very, very weired dependencies issues and broke even the touchpad-driver. but only on lenovo e330...

hope this helps someone

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.