Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a student on winter break so am away from my backup drives and can't just do a fresh install or dd my old working hard drive back into the machine or anything.

background (if you want): I was having some stability problems (which I still haven't figured out quite yet) with qt creator: while trying to add a resource file to a new project, the thing would just insta-close on me. 10 min later I got an internal error message about unity which wasn't all that big of a deal at the time because it wasn't affecting anything else to m knowledge. I read around and heard of other people having similar problems with their unity and driver configurations and I was curious about gnome anyway so I tried the same thing in gnome and got the same result with qt creator so I figured it must be on the level of my drivers.

the problem: I ran apt-get update and apt-get install nvidia-current, rebooted and got a funky setup... the dock icons are the size of my thumb and everything is zoomed in to some size in the upper left-hand corner of my machine. Also, about 2.5 inches on either size of the screen simply aren't being used. The change of screen doesn't happen until the splash login screen. The Ubuntu loading screen is just like my old screen used to be and is still good resolution.

I have an nvidia geforce gt 640m card but am unsure about how to find any more information about it because 12.04 doesn't seem to know what driver I am using or anything whenever I go into the system settings to look around.

images: ... my desktop screenshot ... screenshot of

I'm not sure why everything scaled the way it did or why I can't see half of my desktop anymore. Most of my documents and things were below the visible screen window and I can't access them. None of the scaling that you see in the pictures has been done by me.

needless to say the interface is really annoying and some programs don't have a left-right scroll bar...


share|improve this question
Have you tried going to System Settings > Monitors and change resolution? – Rodrigo Martins Dec 31 '12 at 1:21
yup. wouldn't let me choose anything other than 640x480 – JonHamill Dec 31 '12 at 4:46

After talking to a friend, I have come to viable solution:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf-20130101
sudo rm xorg.conf


share|improve this answer
Thats fun, I guess something created an xorg file with the wrong size. Ubuntu has a blank one these days, so renaming the old one caused the autodetected settings to work. If you had control alt-backspace enabled, which ubuntu dosen't you could simply restart X with that combo rather than rebooting – Journeyman Geek Jan 26 '13 at 1:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.