Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im trying to find a way to activate my HDMI port as when i plug my TV in it comes up with "No signal present" on my TV and I cant find it on the Display tab is Settings either. I have looked around but all the problems seem to be related to no sound and not to nothing happening.

What can I do to activate it? I have a Asus EEE PC X101 CH if thats any help.

share|improve this question
up vote 2 down vote accepted

Try rebooting, with the TV plugged in. Some TVs are pretty silly with such things, as are some cheaper laptop parts.

Failing that, give these steps a try from this posting

sudo add-apt-repository ppa:sarvatt/cedarview
sudo apt-get install add-apt-key
sudo add-apt-key 0x4c96de60854c4636
sudo apt-get update
sudo apt-get install cedarview-drm libva-cedarview-vaapi-driver cedarview-graphics-drivers
sudo update-grub2
sudo reboot

The site also mentions changing your grub config and making sure your not running a PAE kernel. It also suggests disabling AIGLX. I left those steps out because I don't know what they would do. Take a look at the site, see if you think you need to do those steps.

share|improve this answer
I tried logging out and in and rebooting but no luck. In the terminal its under "Atom Processor D2xxx/N2xxx Integrated Graphics Controller" I also believe its Cedar Trail under the Additional Drivers – Mackay508 Dec 30 '12 at 16:03
It worked thank you :) – Mackay508 Dec 30 '12 at 16:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.