Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have successfully repaired my nvidia driver issue so that the driver is loaded correctly.

Within nvidia-settings i can setup my desktop to my needs (2 displays both at 1920x1080, twinview).

After configurating and checking that the displays was set correctly, i clicked "save to x configuration file"

Xorg.conf looks like:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection
Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc ASUS VW247"
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 660 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: 1920x1080 +0+0, DFP-3: 1920x1080 +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

So i assume that the 1920x1080 resolution is correctly saved to xorg.conf. If i now restart my pc or logout/login, i get just both monitors to 1024x768. If i then go to nvidia-settings again i can configurate it successfully again to be working at 1920x1080.

So i think the driver is correctly because the resolution is configureable and work as aspected, but during boot it does not load the correct values.

Anybody does know i can tell my system to use during boot the high resolution?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Your config file seems to be missing info. This can happen because Xorg no longer uses the config file in the same way.

If your nvidia drivers are working fine then start by removing all sections except "device". Make sure to backup the file first of course.

Once X comes back up use Displays (from the dashboard or system setting) to correct the resolution. This will save the setting so that it is "high res" whenever you log in.

Make sure, the first time you make the changes, to actually log out, and not just kill X or issue the reboot command.

It that doesn't work for you you can try editing your settings in Nvidia Settings and saving them to the Xorg config file, but this should not be needed.

Basically the Xorg config structure underwent a huge change a few years ago and now a lot of the well published data is just plain wrong, or leads you down the wrong path. Simply put the Xorg config file should only be used to override things that don't work normally.

share|improve this answer
    
Thanks, this worked like a charm. I removed all configs within xorg.conf just left the device section there. Rebootet. under system settings -> displays i saw then the wrong configurated 1024x768 resolution, i changed this value. log off / log in and finally rebootet. Got the high resolution after reboot then. –  prdatur Dec 30 '12 at 16:32

Your system may be differnt than mine, and you may want specific features that I don't require, but I have found a very useful program called "ARandR" that allows you to manage which monitors are displaying and at what resolution. I have a laptop that I normally have plugged into a monitor. So I had a similar issue, my monitor would, by default, only display at the "nearest" resolution to the highest resolution of the laptop. I know this sounds confusing, but my monitor was the good old aspect ration of 4:3, while my laptop's display was one of those new wide screen ratios, so you can imagine what it looked like.

SO to solve this problem, someone recommended ARandR to me (http://ubuntuforums.org/showthread.php?t=2084045). It basically worked like a charm. Once I log in the settings are immediately set (my laptop monitor terns off and my monitor displays at full resolution). ARandR also let's you save profiles so if I want to take my laptop to a different monitor set-up I can have a profile for it.

Here is the official website: http://christian.amsuess.com/tools/arandr/

there are install instructions there. You can type:

sudo aptitude install arandr

Or just find find it in sypatic and install it from there.

Again, this program works for me, there maybe some features that this program doesn't give you... But this is the best answer I can give.

share|improve this answer
    
Thanks for your answer, but i prefer using direct system tools instead of third-party apps. Would have tried if above solution didn't work, but it did. –  prdatur Dec 30 '12 at 16:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.