Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am new to Linux. I have a Dell Inspiron 15 with a 1st generation Intel Core i3 and Ubuntu 12.10.

My laptop gets heated quickly which doesn't happen on Windows. Also the battery is discharged faster than in Windows. Please help.

share|improve this question

marked as duplicate by Basharat Sialvi, Thomas W., Eric Carvalho, Seth, Radu Rădeanu Jun 30 '13 at 5:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
Possible duplicate askubuntu.com/questions/9820/… and for battery life askubuntu.com/questions/232379/… –  Mukund Dec 30 '12 at 13:39
    
Although I don't understand the internals enough to change them, I believe it has to choose with the optimizations done in the linux kernel. You can either optimize for 1)speed or for 2)battery usage/power consumption. The linux kernel being optimized for speed often outputs a lot of heat. You can install specific software to help but thats the gist –  Liam William Dec 30 '12 at 21:54
    
@john Does your computer overheat then shutdown or just get really hot? –  Liam William Dec 30 '12 at 22:00

3 Answers 3

most probably installing the correct VGA driver can reduce overheating. To install correct VGA driver

you need to do some simple things if your using ubuntu 12.10

  1. first go to software center and type drivers.
  2. in there find additional drivers. and install it.
  3. after installation complete open it. it will search drivers for your VGA card. warning! do not close it. because additional drivers not working properly in 12.10 so once you close you cannot find it anywhere. then you must remove it and re-install it again through software center.
  4. install all available VGA drivers for your machine.
  5. after installation complete it will ask you to restart. you done!.
  6. after restart go to Settings > Details there you can see your VGA name and type.
share|improve this answer
    
Please avoid posting the same answer in more than one place. When tempted to do so, this means that either: (1) the answer should be customized to account for what is different about the different questions, (2) one question should be flagged for closure as a duplicate of another question (you can flag posts with 15 reputation), or (3) the answer should really be a comment, (4) the answer should be posted in the most appropriate place, and one-line comments posted on the other questions summarizing and linking to it. –  Eliah Kagan Jan 12 '13 at 0:20

Most probably, it is due to having several graphic cards enabled simultaneously, usually intel + (Nvidia | ATI). I have this same problem.

You can try to disable one of the graphic cards. You could find additional information in this blog dedicated to Linux hybrid graphics.

share|improve this answer

This is kernel issue. You can reinstall a kernel of your choice through SW manager in ubuntu. I faced the same problem with ubuntu in my laptop and fixed it by reinstalling the same karnel that RHEL 6.4 uses. Hope the same will work fine for you.

share|improve this answer
    
Could you clarify what version of the kernel should be installed? –  papukaija Jun 23 '13 at 22:10
    
This answer is too generic. "I blame the kernel, reinstall it" will usually install the very same kernel. So, please, be specific. –  gertvdijk Jun 23 '13 at 22:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.