Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Gedit and LibreOffice Writer. When I want to write in Hebrew I don't have any problem. When I download a LibreOfiice file in Hebrew I do not have any problem, either. When I download a file that is not a LibreOffice file (which means I am opening it with the Gedit) all I see is àðà äùàéøå ùí åîñôø èìôåï.

Why is that? Is it because I am opening a file with ".str"? Here is an example of website which from there I downloaded the file.

share|improve this question
    
What kind of file are you downloading? Can you give some more details about the file type and it's encoding? I'm not familiar with .str, but googling it shows various kinds of binary or data files that would not open correctly in a text editor. –  chaskes Dec 30 '12 at 15:39
    
I edit the question –  wantToLearn Dec 30 '12 at 16:54
    
It looks like you have wrong encoding or you just don't have correct font. gedit is for mostly for ASCII files (like code), though. –  ZDroid Feb 18 at 21:15
add comment

2 Answers

You need to set the encoding when you open the document. If you right click and choose open with gedit, gedit will display a prompt that lets you choose the encoding. But if you choose the wrong one, it doesn't give you an easy way through the menu to change it abd the prompt doesn't not always display again.

The best thing to do is use the File>Open dialog. In the lower left of the dialog, you'll see a Character Encoding option, which will say Auto Detected. Click the button to see a choice of encodings (there are 3 for Hebrew), be sure to click add after selecting the one you need, then choosing it again from the list on the right. Hebrews Windows and Hebrew Visual both worked, but Hebrew IBM did not.

share|improve this answer
add comment

.srt files are sub-title files, which means they contain the timing and text to be displayed when a video is played. This can be safely opened and viewed in gedit. The reason you are seeing the file the way you are, is because the language is not set to Hebrew and the file is in Hebrew, if I can make out from your question correctly.

To set languages in gedit, go to Tools -> Set Language and set your language to Hibrew. If you cannot find Hibrew, you may need to install it from System Settings -> Language Support -> and install click on "Install/ Remove Languages".

share|improve this answer
1  
Aside from text language I believe there's also an encoding setting in Gedit. –  gertvdijk Dec 30 '12 at 19:09
    
hibrew :) hebrew? too fun to change –  don.joey Dec 30 '12 at 19:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.