Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am running MS Office under wine and would like to print PDF documents.

Installing the official extension via wine does nothing.

share|improve this question

3 Answers 3

up vote 16 down vote accepted

The answer is cups-pdf

sudo apt-get install cups-pdf

If there's no such folder, create PDF at your home:

mkdir ~/PDF

Now you're set to go. From MS Word, do Print -> Select PDF as printer -> wait for the printing to complete (it takes some time).

share|improve this answer
+1, just a note: I didn’t have to manually create the ~/PDF folder; this was done automatically for me (CUPS-PDF version 2.6.1-6, Ubuntu 12.04). – Chriki Dec 12 '13 at 18:17
Once cups-pdf installed, you need to create a new PDF printer from the control panel in Ubuntu. This "printer" will be available for the whole system (including wine). – user351382 Nov 23 '14 at 10:41

cups-pdf didn't work properly for me, here's what I did:

Download the official extension from Microsoft's website. It didn't work for me eihter initially, but this is because I have Microsoft Office installed in a separate Wine prefix.

To find out if you have Word installed in a separate prefix, look at the file ~/.local/share/applications/wine/Programs/Microsoft Office/Microsoft Office Word 2007.desktop. Locate the line that starts with "Exec". On my system it looks like this:

Exec=env WINEPREFIX="/home/rune/.wine_office2007" wine C:\\\\windows\\\\command\\\\start.exe /Unix /home/rune/.wine_office2007/dosdevices/c:/users/rune/Start\\ Menu/Programs/Microsoft\\ Office/Microsoft\\ Office\\ Word\\ 2007.lnk

From this I can see that Office is installed in the prefix /home/rune/.wine_office2007.

Now go to the folder where you downloaded the official PDF add-on. And run the .exe file using the following command, replacing <prefix> with the prefix in the "Exec" line of your Word .desktop file.:

WINEPREFIX="<prefix>" wine SaveAsPDFandXPS.exe

In my case the prefix is /home/rune/.wine_office2007, so the command to install the add-on becomes:

WINEPREFIX="/home/rune/.wine_office2007" wine SaveAsPDFandXPS.exe

After doing this, restart Word, and you should see the option to save as a PDF in the Save As file menu.

share|improve this answer
Make sure that you create the PDF folder in your home directory. Also shut down all programs that use wine and manually kill any wine processes still running (check with ps ax | grep wine): killall wineserver && killall winedevice.exe This should force the list of available printers in Wine (and Word) to be reset. Alternatively you could prefer to reboot. – logion Jun 19 '14 at 8:37

I support runeks' answer.

However, I kept having problems installing the SaveAsPDF.exe extension - it never showed up as being installed.

I finally realized that I had used PlayOnLinux to install Office rather than pure Wine, and this meant using the PoL Wine prefix.

This thread (in Italian!) helped me solve it:

Basically had to look in my /home/name/.PlayOnLinux/wineprefix folder to discover the correct WINEPREFIX path, then used that to run the .exe file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.