Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't get two-finger scrolling to work in LXDE w/ Ubuntu 12.10.

Here's a brief history. I upgraded my machine (an old Dell Inspiron 1200) from Ubuntu 10.04 LTS to Ubuntu 12.10 all in one fell swoop, and then installed LXDE and completely removed all ubuntu-desktop packages using the psychocats instructions (because I greatly dislike Unity). In short, it's more or less basically like Lubuntu now, as far as I can tell. All other programs and settings work just fine -- but not two-finger scrolling.

Help?

(Oh, and there will be bonus points for anyone with right ideas about how to enable "natural scrolling" after I get the two-finger scrolling working!)

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

I found an answer here and have summarized it below.

TWO-FINGER SCROLLING

Create and/or edit a file called mouse.fdi like so:

sudo leafpad /etc/hal/fdi/policy/mouse.fdi

Paste in this stuff:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
 <device>
  <match key="input.x11_driver" string="synaptics">
   <merge key="input.x11_options.VertEdgeScroll" type="string">true</merge>
   <merge key="input.x11_options.HorizEdgeScroll" type="string">true</merge>
   <merge key="input.x11_options.MaxTapTime" type="string">0</merge>
  </match>
 </device>
</deviceinfo>

Save! Reboot! Done!


BONUS: "NATURAL SCROLLING"

Enable "natural scrolling" (AKA "reverse scrolling") by creating a file in the home directory called .Xmodmap like so:

leafpad ~/.Xmodmap

And paste in this stuff:

pointer = 1 2 3 5 4 6 7 8 9 10 11 12

Save! Reboot! Done!


DOUBLE BONUS: DISABLE TAP-TO-CLICK

Open the session autostart file:

sudo leafpad /etc/xdg/lxsession/Lubuntu/autostart

And append this stuff (or simply run it from the command line for a one-off solution):

synclient MaxTapTime=0

Save! Reboot! Done!

share|improve this answer
add comment

Two finger scrolling only works on computers that support it. Yours might not. My Dell Latitude D830 doesn't support two finger scrolling, so I use edge scrolling.

share|improve this answer
2  
Good point, but it worked fine on Ubuntu 10.04 LTS and then again when I upgraded to 12.10. It only STOPPED working when I followed the psychocats instructions and made my system a "pure" Lubuntu. It's quite possible that I removed a package necessary for two-finger scrolling, but I have no way of knowing which package that might be. Or it could be that Lubuntu doesn't support two-finger scrolling. I just don't know. –  jrc03c Dec 30 '12 at 2:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.