Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Some please help! I've been working at this for several days (arg!)

  • Asus P8H77-I (DVI, HDMI, VGA) and an i7-3770 (integrated HD4000 graphics).
  • DVI connected to a 1920x1080 monitor
  • HDMI connected to a 1280x720 Panasonic plasma TV
  • Fresh 12.04 install; no xorg.conf

If I unplug the monitor and reset X, the TV works fine as a primary display. As soon as I plug in the monitor, the TV goes blank (black screen) and the monitor switches on. If I go to "System Settings > Display", I see that both screens are recognized, activated, and set as the proper resolutions.

How can I get both screens to display at the same time? I'm trying to get twin view (as opposed to mirrored, but at this point I'd be happy with either as long as they both display). Any advice would be gretaly appreciated. Thanks.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Nevermind. I was able to resolve this: my TV resolution was not being detected correctly & "System Settings > Displays" was writing odd configurations into my monitors.xml (or maybe it wasn't reading from it properly, I don't know).

Solution: Found modelines for my TV here: http://www.mythtv.org/wiki/Modeline_Database . Added it to my xorg.conf and manually edited my monitors.xml (as opposed to using the "System Settings > Displays" interface).

/etc/X11/xorg.conf:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "record"
    Load  "extmod"
    Load  "dri2"
    Load  "dri"
    Load  "dbe"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "VGA1"
    VendorName     "Unplugged"
    ModelName      "Nothing Plugged In"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "HDMI1"
    VendorName     "Dell"
    ModelName      "DELL S2209W"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier      "HDMI2"
    VendorName      "Panasonic"
    ModelName       "PANASONIC-TV"
    HorizSync       15.73 - 67.50
    VertRefresh     59.94 - 60.0
    Modeline "1208x679" 74.25 1208 1353 1393 1650 679 707 712 750 +hsync +vsync
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
    Identifier  "Card1"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
    Identifier  "Card2"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "VGA1"
    DefaultDepth    24
    SubSection     "Display"
        Modes     "1920x1080" "1280x720" "1208x679" "720x480" 
        Depth       24
    EndSubSection   
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "HDMI1"
    DefaultDepth    24
    SubSection     "Display"
        Modes     "1920x1080" "1280x720" "1208x679" "720x480" 
        Depth       24
    EndSubSection   
EndSection

Section "Screen"
    Identifier "Screen2"
    Device     "Card2"
    Monitor    "HDMI2"
    DefaultDepth    24
    SubSection "Display"
        Modes     "1920x1080" "1280x720" "1208x679" "720x480" 
        Depth     24
    EndSubSection
EndSection

~/.config/monitor.xml:

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="VGA1">
      </output>
      <output name="HDMI1">
          <vendor>DEL</vendor>
          <product>0xa043</product>
          <serial>0x33413055</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="HDMI2">
          <vendor>MEI</vendor>
          <product>0xa060</product>
          <serial>0x17009171</serial>
          <width>1208</width>
          <height>679</height>
          <rate>60</rate>
          <x>1920</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="DP1">
      </output>
      <output name="DP2">
      </output>
  </configuration>
</monitors>

Then from a terminal:

xrandr --output HDMI2 --mode "1208x679"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.