Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a very fresh install of lucid 10.04 64bit, fully upgraded, and with a raft of additional packages added. Amongst them is emacs (23.1+1-4ubuntu7). I habitually launch emacs from a terminal.

I just observed that when I have the GUI emacs (i.e., the result of running emacs not emacs --nw) and I ALT + TAB away from it, each press of ALT + TAB results in the line

** (emacs:7690): CRITICAL **: murrine_style_draw_box: assertion `height >= -1' failed

being output to my terminal window (I assume it's from the stderr of the emacs process).

This didn't happen on jaunty 9.04, for which I had the default jaunty emacs package installed.

How to fix?

share|improve this question

2 Answers 2

This is not a solution, but an easy workaround to this problem is to simply change the theme. The default theme:

System -> Preferences -> Appearance -> Theme

is set at Ambiance. Changing it to Clearlooks solves the problem (and one could simply customize so that it "looks" like any other theme you like).

share|improve this answer
up vote 2 down vote accepted

[Before posting the question, I found the answer and thought it best to get that information into this system. Hence the self answer. I've made my answer community wiki.]

The bug is known, and there is a work-around in this comment on it. I effected the change there suggested; once I closed and reopened emacs, the problem was solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.