Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install VirualBox 4.2 on Ubuntu 12.10 but when this is the error I get:

 The following packages have unmet dependencies:
 virtualbox-4.2 : Depends: libqt4-opengl (>= 4:4.7.2) but it is not going 
 to be installed
 E: Unable to correct problems, you have held broken packages.

And if I try to run the command for dependencies, I get the message that its already installed. I have 64-bit Ubuntu and trying to install 64-bit VirtualBox

The issue seems to be with the linux-headers as I have where as its asking for

share|improve this question
try sudo apt-get install -f – Web-E Dec 29 '12 at 17:34
I get this: The following packages were automatically installed and are no longer required: linux-headers-3.5.0-17 linux-headers-3.5.0-17-generic – M. Ahmad Zafar Dec 29 '12 at 17:38
now try to reinstall virtualbox – Web-E Dec 29 '12 at 17:41
it isn't getting installed in the first place – M. Ahmad Zafar Dec 29 '12 at 17:42
how about downloading the deb file from its site? have you tried it? – nickanor Dec 29 '12 at 17:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.